
Maxim DL 

Początkujący astroamatorzy zwykle po około roku obserwacji, a często nawet szybciej, zaczynają 

interesować się astrofotografią. Zwykle też, po paru próbach, udaje im się podłączyć jakąś kamerę lub 

aparat fotograficzny do teleskopu i zrobić swoje pierwsze zdjęcia nocnego nieba.  

I w tym momencie napotykają kolejny problem – na zdjęciu w zasadzie nic nie widać, lub widać głównie 

jakieś kolorowe szumy, a wszystkie parametry naświetlania były ustawione tak jak u innych – co 

zrobiłem źle... Odpowiedź jest prosta-wszystko jest jak najbardziej w porządku, po prostu zdjęcie należy 

poddać dalszej obróbce elektronicznej w jakimś programie specjalnie do tego celu zaprojektowanym np. 

MaximieDL. Właśnie ten temat chciałbym nieco rozwinąć w tym artykule, przedstawiając krok po kroku 

jak należy użyć tego programu by otrzymać na końcu prawidłowo wykonane i przetworzone zdjęcie. 

Kolejne kroki niezbędne do wykonania dobrego zdjęcia: 

1. Instalacja i konfiguracja oprogramowania 

2. Stworzenie bibliotek kalibrujących zdjęcia (ramki: dark, bias i flat) 

3. Naświetlenie serii ekspozycji  

4. Kalibracja  

5. Usunięcie hot i dead pikseli 

6. Wyrównanie ekspozycji (align) 

7. Uśrednienie klatek (stack) 

8. Balansowanie kolorów - kanały L i RGB 

9. Ostateczna obróbka - poziomy i krzywe 

No cóż - najpierw musimy mieć MaxImDL, 30-dniową wersję testową można pobrać ze strony 

producenta programu: wersja demo MaxImDL. Oczywiście musimy program jeszcze zainstalować i 

odpowiednio skonfigurować. Warto zacząć od ustawień. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.cyanogen.com/downloads/maxim_main.htm


Settings  

 Rys 1. 

Jak widać na zrzucie ekranu (rys.1) należy wybrać menu File>Settings otworzy się wtedy kolejne okno 

 rys. 2 Okno Settings | Site Optics  

 



Warto wypełnić dane z tej zakładki, bo dzięki nim MaxImDL będzie wiedział jakim teleskopem jest 

wykonywane zdjęcie - panel Main Teleskope i gdzie było robione – panel Site location., a także będzie 

znał parametry guidera – panel Guide Teleskope. W panelu lokalizacji mam zaznaczoną opcję Use 

telescope’s location if available, ponieważ standardowo do sterowania teleskopem używam programu 

planetarium TheSky6, który doskonale współpracuje z MaxImDL i bez problemów przekazuje dane o 

lokalizacji miejsca obserwacji, a także współrzędnych obiektu i czasie wykonania zdjęcia do zdjęć 

wykonywanych z pod MaxImDL. Nic nie stoi jednak na przeszkodzie by wprowadzać te informacje 

ręcznie. Po wprowadzeniu wszystkich danych naciskamy guzik OK., który zamyka okno i zapamiętuje 

wpisane przez nas informacje.  

CCD Camera 

Kolejnym bardzo ważnym ustawieniem jest poinformowanie programu jaką kamerą wykonujemy zdjęcia 

i w jaki sposób sterujemy teleskopem. Zacznijmy od kamery: 

 

rys. 3 Menu>CCD 

 



Control Window Wybieramy opcję z menu View>CCD Control Window lub naciskamy ikonkę kamery 

CCD z paska narzędzi. Otwiera na się kolejne okno: 

 rys. 4 Maxim CCD | Setup 

 

W oknie MaxIm CCD przechodzimy do zakładki Setup. W panelu Main CCD Camera naciskamy guzik 

Setup i otwiera na się okno wyboru kamery CCD: 

 

rys.5 Camera Setup 

 



Wybieramy kamerę z rozwijalnej listy Camera Model i ewentualnie w zależności od jej typu 

odpowiednio ustawiamy pozostałe parametry. Tradycyjnie po wprowadzeniu zmian naciskamy guzik OK. 

Możemy już podłączyć kamerę do komputera i wypróbować czy MaxImDL prawidłowo się z nią 

komunikuje, przedtem nie zapomnijmy o włączeniu zasilania kamery. W oknie Maxim CCD (rys.4) 

należy w tym celu po prostu nacisnąć guzik Connect, jeśli wszystko jest prawidłowo podłączone i 

skonfigurowane guzik Connect pozostanie wciśnięty, jeśli coś pójdzie nie tak zostaniemy o tym 

poinformowani w okienku informującym o błędzie kamery. W analogiczny sposób powinniśmy 

skonfigurować kamerę autoguidera w panelu Autoguider. Jeśli nasza kamera ma regulację temperatury, 

po jej podłączeniu uaktywni się guzik Cooler powinniśmy wybrać najniższą możliwą do utrzymania 

przez całą sesję zdjęciową temperaturę przetwornika np. –20 stopni. Temperaturę należy dobierać tak by 

chłodzenie pracowało na około 50% swojej mocy, nie należy raczej przekraczać 70%, przynajmniej w 

przypadku kamer SBIG’a. Pamiętajmy, że im niższa temperatura tym na zdjęciach będziemy mieli mniej 

szumów, a dodatkowo widoczne będą słabsze obiekty, bo ich sygnał stanie się większy niż poziom 

szumów kamery. Producenci SBIG’a polecają np. ustawienie na początek np. –50 stopni, po około pół 

godzinie sprawdzamy jaką temperaturę osiągnęła kamera, zwiększamy tą wartość o 5 stopni i 

teoretycznie powinno być ok., czyli, że kamera powinna pracować na ok. 50% mocy chłodzenia i 

stabilnie trzymać temperaturę. Małe odchylenia typu +/- 0.5 stopnia są normalne i nie należy się nimi 

przejmować. Jeśli posiadamy koło filtrowe powinniśmy o tym poinformować program wybierając 

odpowiedni typ w panelu Filter Whell. Dzięki temu będziemy mogli sterować kołem filtrowym z 

poziomu MaxImDL i wykonać np. serię zdjęć używając kolejno wszystkich filtrów. Po podłączeniu 

kamery możemy od razu przejść do zakładki Expose ustawić w niej czas ekspozycji na np. 5s, zaznaczyć 

opcję Type | Light i nacisnąć guzik Expose. Zrobimy w ten sposób nasze pierwsze zdjęcie i upewnimy 

się, że kamera prawidłowo współpracuje z programem. MaxImDL od wersji 4.58 obsługuje aparaty 

fotograficzne Canona w tym model 300D i potrafi nawet sterować lustrem i długimi czasami naświetlania 

(tej opcji osobiście nie testowałem). Dobrze też spisuje się jako konwerter RAW’ów. Jeśli nie mamy pod 

ręką kamery a chcemy sprawdzić jak działa program, możemy wybrać z listy modeli kamer Simulator, 

program będzie wtedy zachowywał się tak, jakby kamera była fizycznie do niego podłączona, nawet 

wykona przykładowe zdjęcie.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Telescope 

Mamy skonfigurowana kamerę-warto jeszcze skonfigurować teleskop, choć teoretycznie do obróbki zdjęć 

nie jest to konieczne. Z jednej strony dzięki temu w każdym zdjęciu będziemy mieli zapisane informacje 

o jego współrzędnych Ra i Dec, z drugiej co chyba ważniejsze będziemy mogli skorzystać z dobrego 

autoguidera wbudowanego w program. 

 

rys.6 Menu View>Telescope Control Window  

 

Naciskamy Ctrl+T lub wybieramy z menu View>Telescope Contrpl Window, lub naciskamy w pasku 

narzędzi ikonke teleskopu i przechodzimy do okna Telescope Control, w nim wybieramy zakładkę Setup 

i w panelu Telescope z rozwijalnej listy wybieramy odpowiedni typ montażu. 

 rys. 7 Telescope Control | Setup  



Jeśli naszego modelu nie ma na liście, można spróbować podłączyć go przez drivery ASCOM, 

wybierając opcję POTH, wymaga to jednak odpowiedniego skonfigurowania driverów ASCOM i samego 

POTH’a (nie jest to niestety proste). Po wybraniu typu montażu naciskamy guzik z czarnym trójkącikiem 

przy napisie Options i wybieramy z listy menu Setup..., w zależności od typu montażu zobaczymy 

dodatkowe opcje konfiguracyjne, w szczególności należy zwrócić uwagę na wybór odpowiedniego portu 

szeregowego np. COM1 do którego zwykle podłączane są montaże. Po skonfigurowaniu montażu 

wybieramy guzik Connect jeśli wszystko jest prawidłowo ustawione guzik pozostanie wciśnięty a w 

panelu Telescope pojawi się napis Connected. Przechodząc do zakładki Telescope w tym oknie możemy 

sprawdzić czy teleskop jest prawidłowo sterowany przez MaximaDL. W panelu Nudge wpisujemy np. 10 

min i wciskamy guzik N (Nord) – teleskop powinien zacząć się przesuwać i podnieść się o 10 minut 

kątowych. Dzięki tym ustawieniom MaxImDL, będzie automatycznie przepisywać współrzędne obiektu 

do zdjęcia.  

 

Autoguider 

Pozostaje nam jeszcze skonfigurowanie autoguidera. Mamy już skonfigurowana kamerę w autoguiderze, 

powinniśmy jeszcze wytłumaczyć programowi jak ma sterować montażem. Wracamy do okna MaxIm 

CCD (rys.4). Wybieramy zakładkę Guide, naciskamy guzik Options, a następnie wybieramy opcję Guide 

Settings. 

 

rys.8 Maxim CCD | Guide | Options | Guider Settings  

 

Na początek interesuje nas panel Autoguider Output i lista Control Via. Jeśli nasza kamera ma wyjście 

autoguidera w standardzie ST4 to wybieramy opcję Guider Relays, a kabel z wyjścia autoguidera kamery 

łączymy z wejściem autoguidera na montażu (oczywiście o ile montaż ma odpowiednie wejście). Jeśli 



kamera lub montaż nie ma takiego wyjścia wybieramy opcję Telescope lub ASCOM Direct i teoretycznie 

guider powinien nam zacząć działać. Prawidłowe skonfigurowanie guidera to prawde mówiąc temat na 

oddzielny artykuł. W tym miejscu przypomnę może tylko o konieczności skalibrowania guidera przed 

jego użyciem, czyli wybraniu opcji MaxIm CCD | Guide Calibrate i naciśnięciu guzika Start. Pozwoli to 

programowi zorientować się o ile jest obrócona kamera autoguidera w stosunku do osi północ – południe 

i jak duże poprawki powinien wprowadzać przy zmianach pozycji gwiazdy. Polecam również zapoznanie 

się z przydatnym kalkulatorem pod adresem: CCDWare - kalkulator guidera. Dobra wiadomość – to 

koniec konfiguracji programu. Przy kolejnych uruchomieniach MaxImDL oczywiście będzie pamiętał 

wszystkie wprowadzone przez nas ustawienia i jeśli nie zmieniamy sprzętu nie będziemy musieli brnąć 

przez tą listę ponownie. Możemy nareszcie przystąpić do robienia zdjęć. Właściwie wspomniałem już jak 

zrobić pierwsze zdjęcie przy okazji konfigurowania kamery. W MaxImDL jest jednak znacznie lepszy 

sposób na robienie serii zdjęć, a zwykle z taką sytuacją mamy do czynienia zajmując się astrofotografią.  

 

Sequence  

Wybieramy okno MaxIm CCD i zakładkę Sequence, w niej naciskamy Options, a z rozwijalnego menu 

Setup Sequence. 

 

rys.9 MaxIm CCD | Sequence | Options | Setup Sequence  

http://www.ccdware.com/resources/autoguidercalcv4.cfm


W tym oknie możemy zdefiniować sekwencje naświetlania czyli ustalić jakie zdjęcia zostaną po kolei 

wykonane, z jakim binningiem i ile razy zostaną powtórzone, a także wybrać filtr przez który będą 

robione, oczywiście o ile mamy podłączone koło filtrowe. Naciskając w tym oknie guzik Options 

możemy ustalić dodatkowe parametry sekwencji zdjęć, zapisać zdefiniowaną sekwencję do pliku (bardzo 

przydatna opcja przy robieniu sekwencji darków), wczytać zapisaną sekwencję, lub spowodować by 

kamera wykonywała zdjęcia seriami dla wybranego filtra (opcja Group by Slot) , dzięki czemu 

oszczędzamy czas, który byłby tracony na zmiany filtrów przy każdym powtórzeniu sekwencji. Ponadto 

robiąc zdjęcia przy użyciu sekwencji MaxImDL od razu zapisuje je na dysk do wskazanego katalogu 

Options | Set Destination Path z nazwą podaną w polu Autosave FileName. Kolejne zdjęcia z sekwencji 

będą miały dodane do tej nazwy numer zdjęcia i Suffix podany w Setup Sequence. Jest to niesamowicie 

wygodna funkcja programu i grzechem było by z niej nie korzystać. Po zdefiniowaniu sekwencji po 

prostu naciskamy guzik Start i kamera zaczyna wykonywać sekwencje zdjęć zapisując kolejne do 

wskazanego katalogu. 

Bardzo ważne jest ustalenie typu (Type) zdjęcia jakie będzie wykonane. MaxImDL rozróżnia cztery 

rodzaje: Light, Dark, Bias i Flat. Jeśli chcemy wykonać dobre zdjęcie będziemy potrzebować każdego z 

nich. Co nie znaczy, że za każdym razem do każdego zdjęcia, musimy naświetlać wszystkie rodzaje 

ramek kalibracyjnych.  

 

 

 

 

Light  

Ramki typu Light to właściwe zdjęcia obiektów na niebie wykonane z zadanym czasem i przy jakiejś 

temperaturze. Czas i temperatura są o tyle istotne, że od nich zależą ramki Dark, Bias i Flat, które będą 

nam potrzebne do prawidłowej kalibracji zdjęć (Light). Gorąco zachęcam do naświetlania co najmniej 10 

ekspozycji obiektu w jednej sesji, w przypadku Canona nawet 20-30 sztuk. To naprawdę pomaga i bez 

dużej ilości naświetleń, nie ma co marzyć o ładnych zdjęciach, no chyba, że są to bardzo jasne, bardzo 

kontrastowe obiekty np. Księżyc, przy którym zwykle wystarczy nam jedna ekspozycja.  

 

 

 

 

 

 

Dark  

Dark’i wykonujemy zamykając szczelnie teleskop (lub samą kamerę), czyli naświetlając teoretycznie 

czarne klatki. Jeśli mamy kamerę z regulacją temperatury włączmy ją przedtem i odczekajmy, aż 

temperatura się ustali, jeśli fotografujemy np. Canonem, zróbmy serię darków i w nazwie pliku 

zanotujmy sobie przy jakiej temperaturze były robione, najlepiej na koniec sesji zdjęciowej. Jeszcze lepiej 

będzie jeśli podzielmy serie darków na dwie: jedną na początku sesji, a drugą na koniec. Darków 

powinniśmy mieć co najmniej tyle samo co ramek typu Light, najlepiej nawet dwa razy tyle. Pozwoli to 

nam zachować przyzwoity odstęp od szumów na skalibrowanym zdjęciu. Uwaga: darki muszą mieć te 

same czasy naświetlania co ramki typu light i muszą być wykonane w tej samej temperaturze. 



 

rys.10 Przykładowy master Dark  

 

 

 

 

 

 

 

 

Bias  

To ramka wykonana przy szczelnie zamkniętym teleskopie z minimalnym możliwym czasem 

naświetlania, najlepiej zerowym, ale to potrafią robić tylko dedykowane do astrofotografii kamery CCD. I 

w tym przypadku zadbajmy o to by Bias’y były wykonywane w tej samej temperaturze co zdjęcia (Light) 

i również zróbmy ich co najmniej tyle samo co zdjęć. Biasy zniwelują nam wszelkie niejednorodności 

związane z sama matrycą i jej często nierównym dla każdego piksela tzw. sygnałem Dark Current. Bez 

dobrze zrobionych ramek Dark i Bias właściwie nie ma co np. poważnie myśleć o fotometrii, którą 

MaxImDL może dla nas wyliczyć ze zdjęcia. 



 

rys.11 Przykładowy master Bias  

 

Flat  

To najtrudniejszy do wykonania typ ramek kalibrujących. Chodzi o to by sfotografować nierównomierne 

rozłożenie natężenia światła docierającego do różnych miejsc przetwornika, wynikające np. z 

winietowania teleskopu lub niejednorodnego poziomu tła nieba spowodowanego przez Light Pollution, 

czy po prostu gradientu powstającego na niebie o świcie. Dodatkowo przy pomocy flatów pozbędziemy 

się śladów wszelkich paprochów, które osiadły nam na przetworniku lub optyce i są potem widoczne na 

zdjęciach. 



 

rys.12 Przykładowy master Flat 

 

Jak to zrobić? Nie ma jednej dobrej metody. Można sobie pomagać przy pomocy tzw. Light Box’ów, 

można próbować fotografować niebo o zachodzie lub wschodzie słońca (koniecznie wtedy gdy nie ma na 

nim już widocznych gwiazd, można sobie pomagać mocnym rozostrzeniem teleskopu, dzięki czemu 

gwiazdy, które są widoczne nawet na dość jasnym niebie o wschodzie słońca rozmywają się i nie są 

widoczne na flacie. Ja osobiście stosuję najprostszy Light Box, czyli białą koszulke naciągniętą na 

teleskop i jasno oświetlony biały sufit na który pod kątem prostym (czyli w tym przypadku pionowo do 

góry) kieruje teleskop. Flaty należy naświetlić z takim czasem by wartość ADU (czyli jasność pikseli 

zdjęcia ) wynosiła około połowy maksymalnej możliwej jasności. Czas naświetlania flata należy dobrać 

eksperymentalnie. Powinno być dobrze na nich widać winietowanie, niejednorodności i brudy z 

przetwornika. Flaty koniecznie muszą być czarno białe. W przypadku kamer z kołem filtrowym należy 

sobie naświetlić flaty do każdego filtra oddzielnie. Do flatów powinniśmy sobie również naświetlić darki 

z odpowiednimi czasami i biasy wykonane przy tej samej co flaty temperaturze. Doradzał bym też 

zrobienie wszystkiego w tej samej temperaturze co zdjęcia, ale w zasadzie nie jest to konieczne. 



MaxImDL sam potem dobierze odpowiednie darki i biasy do flatów, o ile oczywiście go o to poprosimy, 

definiując właściwości kalibracji. Warto również zwrócić uwagę na kąt kamery w teleskopie, przy 

niesymetrycznym winietowaniu będzie on miał duże znaczenie dla prawidłowego wykonania flata. Jak 

łatwo przewidzieć, robiąc flaty należy włożyć kamerę do teleskopu pod tym samym kątem pod jakim są 

lub będą wykonywane zdjęcia. Robiąc sobie kreskę na wyciągu i kamerze (np. naklejając kawałek 

kolorowej taśmy izolacyjnej) ułatwimy sobie utrzymanie tego samego kata przy każdej ekspozycji.  

Kalibracja – przykład  

Zdjęcie przed kalibracją: 

 

rys.13 Zdjęcie przed kalibracją 

 

 

 

 

 



Zdjęcie po kalibracji: 

 

rys.14 Zdjęcie po kalibracji 

 

Proszę zwrócić uwagę na wartość StdDev w tle zdjęcia (zaznaczony kwadrat) i zobaczyć o ile zmieniło 

się odchylenie standardowe w ciemnej części zdjęcia. Przed kalibracją to było 186, po już tylko 32, 

można z tego wywnioskować, że szumy spadły aż sześciokrotnie. Przy okazji znikła większość hot 

pikseli. Naprawdę jest więc o co walczyć.  

Kalibracja – Ustawienia  

Przy pomocy sekwencji naświetliliśmy już sobie serie darków, biasów i flatów. Teraz powinniśmy 

wskazać w MaxImDL, gdzie je zapisaliśmy i który plik odpowiada jakiemu rodzajowi ramki. Czeka nas 

tu miłe zaskoczenie, bo program ma doskonale opracowaną kwestie tworzenia bibliotek plików 

niezbędnych do kalibracji. Zaczynamy od wybrania z menu pozycji Process>Set Calibration 



rys. 15 Menu>Process>Set 

Calibration  Otworzy się nam okno Set Calibration: 

 

rys.16 Okno Set Calibration  



Jeśli zapisaliśmy wszystkie pliki typu dark, bias flat w jednym katalogu to możemy skorzystać z panelu 

Auto-Generation i naciskając na guzik z trzema kropkami wskazać ten katalog. A następnie nacisnąć 

guzik Auto-Generate. I to w zasadzie wszystko. Jedyne co nam pozostanie to ustalić jak mają być 

uśredniane ramki kalibrujące – czyli w opcji Combine Type wybrać Median. Jeśli chcemy sobie na 

podstawie bibliotek zrobić master darki, flaty i biasy (co zdecydowanie, nawet kilkakrotnie przyspieszy 

kalibracje zdjęć) naciskamy guzik Replace w/Master. Następnie należy na górze okienka zaznaczyć 

wszystkie opcje: Calibrate Bias, Calibrate Dark, Calibrate Flat, Dark Substract Flats i Bias Substract 

Flats. Jeśli jakiegoś typu ramek kalibrujących akurat nie mamy możemy pozostawić tą opcję 

niezaznaczoną. Funkcja Auto-Generate zadziała pod warunkiem, że wszystkie ramki kalibrujące były 

wykonane z pod MaxImDL, kamerą która posiada regulacje temperatury i były zapisane w plikach typu 

fits. Fotografując Canonem będziemy musieli sami utworzyć odpowiednie grupy plików (Add Group) i 

dodać do nich właściwe pliki. Po zdefiniowaniu biblioteki plików nie należy już ich usuwać bądź 

zmieniać ich nazw z poziomu Windows, bo MaxImDL nie będzie mógł ich wtedy odszukać na dysku i 

całą czynność konfiguracji bibliotek będzie trzeba zaczynać od nowa. Warto zadbać o prawidłową 

strukturę katalogów z plikami kalibrującymi. Ja stosuje jeden katalog dla jednej temperatury, ewentualnie 

pod tym katalogiem warto sobie utworzyć jeszcze podkatalogi na Biasy, Flaty i Darki. Pozwala to potem 

na wielokrotne użycie tych samych plików kalibrujących, a z drugiej strony ułatwia zdefiniowanie 

bibliotek kalibrujących zdjęcia. Po prostu wskazujemy wtedy katalog nadrzędny do katalogów z 

poszczególnymi temperaturami i naciskamy Auto Generate. Wygodne jest również w nazwie katalogu 

nadrzędnego zapisać sobie datę wykonania ramek kalibrujących. 

 

rys.17 Przykładowa struktura katalogów z plikami kalibrującymi  



Tym sposobem dobrnęliśmy do miejsca od którego zaczynamy właściwą obróbkę i wykonywanie zdjęć. 

Pamiętajmy o tym, że dobrze zdefiniowana biblioteka dobrze zrobionych plików kalibrujących zdjęcia, 

posłuży nam wiele razy i jest kluczem do prawidłowej obróbki zdjęć astronomicznych. 

Do naświetlenia zdjęcia posłużymy się jak zwykle sekwencją. Naświetlmy serie zdjęć i zapiszmy je we 

wskazanym w MaxIm CCD | Sequence > Options > Set Destination Path katalogu pod nazwą na 

przykład: Test_ LRGB. 

 

rys.18 Przykładowa sekwencja LRGB  

 

Warto sobie zapisać tą definicję sekwencji na przyszłość, naciskając Setup Sequence > Options > Save 

Sequence As i nazywać ją np. LRGB_300s. Jak widać zamierzamy naświetlić dziesięć ekspozycji dla 



każdego z filtrów RGB z binning’iem x2 i czasem 180s, oraz 10 ekspozycji luminancji z binning’iem x1 i 

czasem 300s.  

Dobieramy czas ekspozycji  

Podane w przykładzie czasy ekspozycji są typowe dla w miarę jasnych obiektów dla co najmniej 10’’ 

teleskopu ze światłosiłą na poziomie F5 no i oczywiście czułej kamery CCD. Tak naprawdę dla każdego 

obiektu w zależności od jego jasności należy dobrać indywidualnie czas naświetlania, choć zwykle nie 

bawimy się w szczegóły i stosujemy gradację czasów typu 1,2,3,5 10,15,20 minut i dla takich czasów 

naświetlania warto mieć przygotowane biblioteki darków, flatów, i biasów w funkcji temperatury. Warto 

też zastanowić się dlaczego kanały RGB naświetlamy z binning’iem x2 i z krótszymi czasami ekspozycji. 

Powód jest trywialny-oszczędność czasu: o ilości szczegółów i dynamice zdjęcia decyduje kanał 

luminancji, RGB służy w zasadzie tylko do naniesienia kolorów na luminancje. Możemy więc sobie 

pozwolić, na nieco gorszą jakość ekspozycji kolorowych, większą ilość szumu w tych klatkach i mniejszą 

ilość szczegółów. Często stosowane jest nawet zmniejszenie o połowę ilości ekspozycji dla filtrów RGB, 

często pomimo binning’u stosowane są jednak te same czasy ekspozycji co dla kanału L. Spowodowane 

jest to tym, że kolorowe filtry dość mocno tłumią sygnał i chcąc zachować podobną jasność obiektu w 

składowych RGB jak w kanale L musimy po prostu odpowiednio zwiększyć czas naświetlania, bądź przy 

tym samym czasie naświetlania użyć czulszego przetwornika (czyli właśnie włączyć binning). Nie ma 

chyba złotego środka i uniwersalnych nastawień czasu, ilości ekspozycji i binning’u. Dla każdego 

przetwornika, teleskopu, zestawu filtrów, a wręcz obiektu są one dobierane indywidualnie i nie ma innej 

drogi do dobrych ustawień niż eksperymenty. Oczywiście osoby robiące zdjęcia kamerami kolorowymi 

mają ten problem z głowy bo naświetlają wszystkie cztery kanały jednocześnie z tym samym czasem 

usuwając z sekwencji wpisy dotyczące kanałów RGB.  

Dobieramy ilość ekspozycji  

Im lepsze (ładniejsze), z mniejszą ilością szumów chcemy zrobić zdjęcie, tym ilość ekspozycji powinna 

być większa. Ogólne zalecenie jest by nie było to mniej niż 10. Ja dodał bym od siebie, że w zasadzie 

możemy zrobić nawet jedna ekspozycję, ale oczywiście zdjęcie wtedy będzie mocno zaszumione. 

Znaczące różnice w poziomie szumów będą widoczne przy zmianach co najmniej o pięć ekspozycji. Tak 

więc albo naświetlamy 5 ekspozycji, albo 10, jeszcze lepiej 15 itd. Warto zapoznać się z kalkulatorem 

przygotowanym przez firmę CCDWare na stronie: CCDWare - Kalkulator ilości ekspozycji  (wybieramy 

z lewego menu Sub Exposure Calculator). I zerknąć na przygotowane kiedyś przeze mnie zestawienie: 

 

rys.19 Ilość ekspozycji, a szum  

 

Pamiętajmy też, że im niższą temperaturę kamery ustawimy, tym szumy będą mniejsze, więc będziemy 

mogli pozwolić sobie na mniejszą ilość ekspozycji, lub przy tej samej ilości ekspozycji zyskamy na 

stosunku sygnał szum co pozwoli nam dostrzec szczegóły, które przy małej ilości ekspozycji ginęły w 

szumie. 

http://www.ccdware.com/resources/


 

rys.20 Poziom szumów w funkcji temperatury dla kamery SBIG STL11000M 

Po tak gruntownym przygotowaniu teoretycznym samo wykonywanie zdjęć to już czysta przyjemność. W 

MaxImDL w oknie MaxIM CCD | Sequence po zdefiniowaniu sekwencji naciskamy po prostu guzik 

Start. Pamiętajmy, żeby wcześniej włączyć kamerę i pozwolić jej uzyskać zadaną temperaturę. MaxImDL 

naświetli nam wszystkie klatki i zapisze je we wskazanym katalogu. Mamy więc nareszcie materiał 

wejściowy. Przystępujemy do jego obróbki. 

Wczytujemy do MaxImDL wszystkie ekspozycje menu File>Open lub po prostu przeciągamy myszką w 

okno programu wybrane pliki. Ponieważ wcześniej przygotowaliśmy sobie biblioteki do kalibracji, na 

etapie obróbki zdjęć czynność ta jest trywialna. Wystarczy, że naciśniemy jeden guzik z paska narzędzi 

Calibrate All i po kłopocie (lub wybranie menu Process > Calibrate All). Wszystkie parametry kalibracji 

ustaliliśmy wcześniej w oknie menu Process > Set Calibration. Kalibracje zdjęć należy koniecznie 

wykonać najpierw, na samym początku obróbki, w szczególności przed operacją Combine czy Align, lub 

wykonywaniu na nich jakichkolwiek operacji. 



 

rys.21 Kalibracja-Calibrate All  

 

Usuwanie Hot i Dead Pikseli  

Po kalibracji warto jeszcze usunąć z wszystkich klatek pozostałe mimo wszystko pojedyncze hot piksele. 

Posłużmy się do tego celu (by nie powtarzać żmudnie tych czynności na wszystkich klatkach ręcznie) 

komendą menu View>Command Sequence ( lub CTRL+Q): 



 

rys.22 Command Sequence i Hot / Dead Pixel 

 

Po otworzeniu okna Command Sequence naciskamy czerwony przycisk nagrywania. Następnie 

wybieramy menu Filter>Cernel Filters i zaznaczamy Hot Pixel, naciskamy OK. Operacja Filter, Kernel 

Filter została dopisana do listy w oknie Command Sequence, a ze zdjęcia zostały usunięte Hot Piksele, 

naciskamy jednak guzik Undo (lub Ctrl+Z) cofnięcia operacji, bo będziemy chcieli ją wykonać jeszcze 

raz dla wszystkich zdjęć, a jednocześnie nie chcemy zmieniać bieżącego zdjęcia. Następnie w podobny 

sposób nagrywamy sobie operacje usuwania Dead Pikseli, czyli wybieramy menu Filter>Kernel Filter i 

zaznaczmy opcje Dead Pixel, no i znów po wykonaniu operacji naciskamy Undo. W tym kroku 

przetwarzania dla niektórych zdjęć warto przeprowadzić operacje usuwania gradientu, czyli menu 

Filter>Auto Remove Gradient, lub również tylko dla niektórych zdjęć można w tym momencie wykonać 

operacje automatycznego wyrównywania tała czyli menu Filter>Auto Flatten Background. Nagrywając 

sekwencje zawsze po wykonaniu jakiejś operacji cofamy ją. Gdy nagraliśmy już wszystkie operacje które 



chcemy wykonać na zdjęciach zatrzymujemy nagrywanie naciskając guzik STOP z czarnym 

kwadracikiem. Następnie zaznaczamy wszystkie operacje Undo i usuwamy je z listy komend do 

wykonania naciskając czerwony krzyżyk. Przygotowaną sekwencje możemy zapamiętać na przyszłość 

naciskając guzik Save. Kolejnym krokiem jest wybranie zdjęć na których chcemy wykonać sekwencje 

komend. W tym celu naciskamy guzik oznaczony >> (Toggle Single Multiple) następnie naciskamy 

guzik Images, zaznaczamy wszystkie zdjęcia i naciskamy OK. Teraz już możemy wykonać naszą 

sekwencje przetwarzania zdjęć naciskając guzik Play (dwa czarne trójkąciki) i poczekać na zakończenie 

operacji. 

Następnym krokiem jest wyrównanie (Align) klatek, wybieramy ikonke Align (na lewo od czerwonego 

Plusa) lub menu Process>Align otwiera nam się okno wyboru zdjęć. Ponieważ chcemy wyrównać 

wszystkie zdjęcia naciskamy guzik Add All a następnie guzik OK. 

 

rys.23 Align-wybór plików do wyrównania  

 



Zdjęcie referencyjne  

Otwiera nam się kolejne okienko, pozwalające na wybór klatki referencyjnej względem, której będą 

wyrównywane pozostałe zdjęcia. W tym oknie możemy też wybrać metodę wyrównywania zdjęć w 

rozwijalnym menu Align Mode. Polecam Auto – star maching, jeśli nie chce zadziałać to należy wybrać 

Manual 2 stars i wskazać myszką na każdej klatce dwie te same gwiazdy. Program najpierw będzie 

chciał, żebyśmy wskazali pierwszą gwiazdę na wszystkich zdjęciach, a następnie drugą. Po wskazaniu 

gwiazdy na wszystkich klatkach usłyszymy dźwięk informujący nas, że wskazaliśmy pierwszą gwiazdę, i 

program zacznie oczekiwać na wskazanie drugiej gwiazdy. W trybie Auto oczywiście mamy ten problem 

z głowy. Pozostaje nam jedynie wciśnięcie guzika OK. i poczekanie aż program wyrówna wszystkie 

klatki. 

 

rys. 24 Align - wybór referencyjnej klatki i metody wyrównywania zdjęć 



Kolejnym krokiem jest uśrednienie wszystkich klatek. Wybieramy menu Process > Combine (lub z paska 

narzędzi ikonkę z czerwonym plusem): 

 

rys.25 Menu Process > Combine  

 

Otwiera nam się okno wyboru plików do uśrednienia identyczne jak przy wyrównywaniu klatek, 

wybieramy wszystkie wczytane zdjęcia i naciskamy guzik OK. Otwiera się kolejne okno Combine 

Images: 



 

rys.26 Okno składania zdjęć  

 

Należy w tym miejscu zwrócić uwagę na okno Screen Strech. Zmienia ono poziomy bieli i czerni w 

wyświetlanym na ekranie zdjęciu. Poziomy należy dobrać (manipulując czerwonym i zielonym 

trójkącikiem) tak, by jak najlepiej widzieć jakiś ważny dla nas fragment zdjęcia. W tym przypadku jest to 

jądro komety. Pozwoli to nam na trafny wybór klatki referencyjnej, która powinna być jak najlepszej 

jakości, czyli nie poruszona, ostra, z dobrym kontrastem, ładnymi okrągłymi gwiazdkami. Żeby nie 

powtarzać operacji Screen Streach dla każdego zdjęcia po wybraniu właściwych poziomów naciskamy 

ikonkę Equalize Screen Streach, co przenosi zadane przez nas ustawienia do wszystkich zdjęć i pozwala 

nam łatwiej je porównywać. Kolejne klatki wyświetlamy naciskając guzik Next lub Previous Image. 

Wybrane najlepsze zdjęcie zaznaczamy naciskając guzik Set As Reference. Ważne jest też byśmy wybrali 

właściwy sposób składania klatek. Służy do tego panel Output. Moim zdaniem najlepszy jest algorytm 



Sigma Clip, ale nic nie stoi na przeszkodzie, żeby wypróbować inne. Dla przykładu SD Mask będzie 

nieco lepiej usuwać niechciane zwykle ślady przelotu satelitów. Po wybraniu klatki referencyjnej i 

metody składania zdjęć pozostaje nam jedynie nacisnąć guzik OK i poczekać aż program uśredni nasze 

zdjęcia. Metodę wyrównywania zdjęć możemy w tym miejscu ustawić na None, ponieważ wyrównaliśmy 

zdjęcia w poprzednim kroku obróbki. Uśrednione zdjęcie będzie miało nazwę ze znakiem X w miejscach 

gdzie nazwy uśrednianych plików się różnią w tym przypadku będzie to: 17P_Holmes_60s-00X_L (bo do 

uśrednienia wzięliśmy dla przykładu pierwsze pięć klatek). 

 

rys.27 Uśrednione z pięciu ekspozycji metodą Sigma Clip zdjęcie komety 17P/Holmes 

  

Pozostaje nam jeszcze zapisanie uśrednionej klatki do pliku czyli menu File>Save. Najlepiej na tym 

etapie zapisywać zdjęcia w formacie FITS. Pozwala to nam np. na sprawdzenie w Fits Header co program 

zrobił z naszym zdjęciem (CTRL+F) : 



 

rys.28 Fits header 

Powyższe czynności, czyli kalibracja, usuwanie hot pikseli, wyrównywanie i uśrednianie należy 

powtórzyć oddzielnie dla serii zdjęć z każdego kanału RGB. Na koniec zamykamy wszystkie pliki, 

otwieramy jedynie uśrednione klatki LRGB i wyrównujemy je wszystkie do kanału L (luminancji). Jeśli 

zdjęcia z kanałów RGB robiliśmy z binning’iem x2 to powinniśmy je przedtem powiększyć dwukrotnie 

czyli dla każdego kanału wybrać opcje menu Process>Double Size. Czeka nas teraz zadanie wyrównania 

balansu kolorów. Jeśli zdjęcia robiliśmy kolorową kamerą na przykład Canonem to powinniśmy je rozbić 

do trzech kanałów używając opcji menu Color>Split Tricolor.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Balansowanie Kolorów  

Wybieramy menu Color>Combine Color. Otwiera nam się okno Combine Color: 

 

rys.29 Okno Combine Color – balansowanie poziomu bieli  

 

Zaznaczamy w panelu Conversion Type opcje RGB i Bgd Auto Equalize. Przypisujemy odpowiednie 

pliki do odpowiednich kanałów (o ile nie wpisały się same). W okienku Preview Image ustalamy sobie 

właściwą skalę, tak by widzieć najistotniejszy fragment zdjęcia, następnie tupiemy w nie i 

dostosowujemy Screen Stretch. Mamy wstępny podgląd tego jak będzie wyglądać kolorowe zdjęcie. Jak 

widać nie jest najlepiej – jest zdecydowanie za dużo niebieskiego. Sprawdźmy dokładniej co się dzieje. 

Naciskamy guzik Full Screen – co pozwala nam podejrzeć składania zdjęcia do RGB na całym ekranie i 

użyć na nim wykresu Line Profile (naciskamy Ctrl+L a następnie myszką zaznaczamy okolice jądra 

komety) 



 

rys.30 Wykres jasności poszczególnych kolorów  

 

Na wykresie widzimy, że faktycznie niebieskiego jest zdecydowanie za dużo. Jądro przecież powinno być 

białe. Poprawiamy współczynniki kolorów (w tym przypadku zwiększamy udział czerwonego i 

niebieskiego) tak długo, aż szczyty wykresów dla poszczególnych kolorów wyrównają się, czyli jądro 

komety będzie białe: 



 

rys.31 Zbalansowane poziomy poszczególnych kolorów  

 

Naciskamy guzik OK, i to wszystko. Mamy już prawidłowo zbalansowane kolory. Pozostaje nam zapisać 

efekt pracy do pliku. Powinnismy w tym przypadku użyć formatu TIFF bo w praktyce i tak będziemy 

dalej zdjęcie obrabiać w Photoshopie. Pozostało nam jeszcze do zrobienia ustalenie poziomów i 

krzywych jasności, a także nałożenie luminancji na przygotowane przed chwilą kolorowe zdjęcie w RGB. 

Możemy to zrobić również w MaxImDL, ale Photoshop zrobi to znacznie lepiej i wygodniej. Dodatkowo 

można też w tym momencie zapisać w formacie TIFF kanał luminancji, nad którym dalej będziemy 

pracować w już Photoshopie. Choć nic nie stoi na przeszkodzie, żeby rozwinąć zdjęcie w MaxImDL tyle, 

że jest to zdecydowanie mniej wygodne. Kluczowe w tym momencie jest zadbanie o zapis zdjęcia z 16 

bitową głębią kolorów, dlatego właśnie zapisujemy je w formacie Tiff, a nie JPG: 



 

rys.32 Zapis zdjęcia w formacie Tiff  

 

Ważne jest by wyłączyć funkcje Auto Stretch i ustalić Size Format na: 16 bit int. Warto zauważyć, że do 

tego momentu nie ingerowaliśmy w ogóle w poziomy i krzywe jasności w zdjęciu. Jedyne co zrobiliśmy, 

to kalibracja, zmniejszenie poziomu szumu i pozbycie się hot pikseli i innych defektów ze zdjęcia. 

Złożyliśmy też z poszczególnych czarno białych składowych kolorowe zdjęcie. Wykresy kolorów na 

przykładowym zdjęciu są jakby przesunięte. To normalne dla poruszających się na tle gwiazd obiektów 

takich jak komety i robienia zdjęć oddzielnie dla poszczególnych kanałów. Po prostu kometa zdążyła się 

pomiędzy kolejnymi zdjęciami przesunąć na tle gwiazd, a poszczególne klatki wyrównywaliśmy na 

gwiazdach a nie na jądrze komety. 

Możemy dla przykładu rozwinąć zdjęcie w MaxImDL. Będziemy posługiwać się na przemian narzędziem 

Levels i Stretch (menu Process>Levels i Strtch). Zaczynamy od Levels i przesuwamy nieco w lewo 



zielony (środkowy) trójkącik, a prawy-niebieski odsuwamy w prawo do końca głównej części histogramu 

i naciskamy OK. 

 

rys.33 Poziomy  

 

Następnie w oknie Screen Stretch przesuwamy czerwony i zielony trójkącik tak by obejmowały główną 

część histogramu. Nigdy nie należy przesuwać czerwonego trójkąta poza początek histogramu bo 

obetniemy sobie ciemne partie zdjęcia i pozostana one po prostu czarne bez żadnych półtonów. Następnie 

wybieramy menu Process>Stretch... i zaznaczamy opcje tak jak na ekranie poniżej: 



 

rys.34 Stretch – rozciągamy histogram  

 

i naciskamy OK. W przypadku tego zdjęcia wystarcza tylko dwukrotne powtórzenie tej operacji by 

histogram był rozciągnięty na całą szerokość wykresu. W przypadku ciemniejszych zdjęć czynności te 

należy powtarzać tak długo aż zdjęcie będzie dostatecznie jasne, a jednocześnie nie będzie widoczny 

nadmiernie szum. Na koniec możemy jeszcze poprawić nieco kontrast przy pomocy krzywej jasności 

menu Process>Curves: 



 

rys.35 Krzywa jasności-podbijanie kontrastu 

  

I gotowe - zapisujemy zdjęcie w formacie Tiff, a jeśli chcemy je pokazać w internecie używamy formatu 

JPG tyle, że w przypadku jpg’ów zaznaczamy opcję Auto Stretch przy zapisie pliku. 

 

 

 

Warto jeszcze przed przystąpieniem do obróbki zdjęć zapoznać się z dobrymi przykładami jak 

prawidłowo skalibrować monitor, tak by inni zobaczyli twoje zdjęcie w podobnych odcieniach jakie ty 

widzisz na ekranie:  



Poziom czerni  

Gamma a także pamiętać o tym, że nasze oczy w przeciwieństwie do kamer CCD nie odbierają światła 

liniowo tylko logarytmicznie: Prawo Webera-Fechnera 

 

Wypadało by oczywiście pokazać zdjęcie jakie powstało wyniku prezentowanej tutaj metody obróbki: 

 

rys.36 Ostateczne zdjęcie w LRGB 

http://trurl.asua.org.pl/photo/books/calib/blacklevel.xml
http://trurl.asua.org.pl/photo/books/calib/gamma.xml
http://pl.wikipedia.org/wiki/Prawo_Webera-Fechnera


Zazwyczaj tak jak wspominałem ostateczny szlif zdjęcia robię jeszcze w Photoshopie, tutaj dla czystości 

wywodu postanowiłem ograniczyć się do podstawowych tylko narzędzi zawartych w MaxImDL. Efekt 

działań jest jednak chyba zadowalający.  

Trzeba pamiętać jednak, że to co zobaczymy ostatecznie na zdjęciu w największym stopniu zależy od 

warunków obserwacji i pogody, w następnej kolejności od użytego sprzętu, a dopiero na samym końcu 

od obróbki komputerowej, choć z pewnością na tym ostatnim etapie – niezmiernie łatwo jest zepsuć 

nawet najlepszy materiał.  

Warto też wiedzieć, że większość narzędzi użytych tu do obróbki zdjęć astronomicznych znajdziemy w 

bezpłatnych programach takich jak np. DeepSkyStacker, czy PixInsight i wielu-wielu innych. 

MaxImDL jest programem, który wybrałem ze względu na jego doskonałą współpracę z kamerami 

SBIG’a, których używam, ponadto ma doskonale zorganizowaną bibliotekę do kalibracji zdjęć (co w 

moim odczuciu jest jego główną zaletą) no i jest po prostu standardem w świecie astrofotografii.  

Na co dzień MaxImDL jest używany przeze mnie tylko do robienia zdjęć i ich kalibracji, prawie nigdy do 

ostatecznej obróbki, choć jak widać na załączonym przykładzie – bez problemów można w nim zrobić 

całkiem przyzwoite zdjęcie. Kometę 17P/Holmes z tego samego materiału, ale z końcówką obróbki w 

Photoshopie można zobaczyć w galerii na mojej stronie www: 17P/Holmes  

 

Mam nadzieję, że ten tutorial będzie pomocny początkującym astrofotografom we wstępnej obróbce 

zdjęć i pomoże im przebrnąć przez dość jednak złożone początki dającego bardzo wiele satysfakcji 

hobby.  

Czystego nieba 

Jacek Pala 

 

 

http://www.astronomia.slupsk.pl/Galeria_Zdjecie.aspx?FotoId=340

