Jump to content
mario2005

Problemy z powiadamianiem na e-mail

Recommended Posts

Od pewnego czasu nie dostaję powiadomień z forum na e-mail. Nie dochodzą zarówno subskrypcje jak i powiadomienia o wiadomościach.

Najdziwniejsze jest to że raz za czas pojawi się takie powiadomienie jakby nigdy nic.

Konto mam na tlenie, antyspam i inne filtry nic nie wychwytuja czyli poprostu nic z forum nie wychodzi albo idzie w kosmos.

 

Jeśli ktoś z was ma taki problem albo udało mu sie go rozwiązać proszę o odzew w tym temacie.

 

pzdr

Mariusz

Share this post


Link to post
Share on other sites

Jeśli coś idzie do spamu to wiem o tym. Jeśli zablokowano wirusa to zdaje sie też mam o tym informację.

 

Kto ma poczte na tlenie i dostaje powiadomienia bez problemu - piszcie.

Share this post


Link to post
Share on other sites

Ja mam konto na tlenie. A no ostatnią wiadomość mam z dnia 2008-06-11. A po tym dniu miałem mnóstwo nowym wiadomości ale ale powiadmienia nie przychodzą. :unsure:

Share this post


Link to post
Share on other sites

Czyli najprawdopodobniej tlen leci w kulki.

 

Kto ma jeszcze problem na tlenie lub innych portalach?

Share this post


Link to post
Share on other sites

Witam!

Mój e-mail nie jest na tlenie. Ostatnia wiadomośc z forum jaką dostałem jest z 11.06. Później otrzymałem kilka PW a na mailu cisza.

pzdr. Zbyszek

Share this post


Link to post
Share on other sites
Guest polaris

Ja mam Tlena i nie dostaję info o PW. Jakiś czas temu doszło jedno info mocno spóźnione, ale potem cisza.

Share this post


Link to post
Share on other sites

Właśnie 11.06 u mnie też chyba tak było.

Pytanie do technicznych od forum.

Co zmienialiście 11.06 na forum?

Share this post


Link to post
Share on other sites
Właśnie 11.06 u mnie też chyba tak było.

Pytanie do technicznych od forum.

Co zmienialiście 11.06 na forum?

Kompletnie nic. Problem w tym, że poczta "automatyczna" blokowana jest na poziomie komunikacji serwera i wy o tym nic nie będziecie wiedzieć. Generalnie 3/4 wiadomości wysyłanych przez nasz sewer (czyli automatyczne) wraca z blędem. Nie ma wątpliwości, że to po prostu oszczędzanie ruchu na darmowych skrzynkach. Poczta automatyczna to większa częśc ruchu w darmowych usługach, więc jej ograniczanie jest w interesie dostawcy usług.

 

Z tego wynika znacznie większy problem - majle potwierdzające rejetracje też potrafią się odbijać od serwerów darmowych.

 

Może czas wrócić do ideii maili w domenie AF - user@astro-forum.org, które nie miałyby żadnych ograniczeń?

Share this post


Link to post
Share on other sites

Dziwne jest tylko to że koledzy maja konta na różnych portalach a data jest zbieżna. Może to firma na której stoi astroforum ogranicza? Ale wtedy to by chyba wszystkie powiadomienia cięło a nie tylko niektórym użytkownikom.

Ja napisałem do o2.pl w tej sprawie i jestem ciekawy co oni powiedzą.

 

Idea maila na astroforum jest kusząca ale skoro do tej pory było ok to trzeba walczyć aby ten stan powrócił.

 

 

ps. dzis dostałem powiadomienie z subskrypcji z 05.07 ciekawe że z takim opóźnieniem dotarło

Edited by mario2005

Share this post


Link to post
Share on other sites

Pisz, nie sądze, żeby ci napisali coś wartościowego - a na pewno nie to, że tną pocztę automatyczną. Faktem jest, że ostatnimi czasy w ogóle z mailami dzieją się niedobre rzeczy. To wszystko w imię słusznej walki ze spamem, którego jest masa. Problem tylko w tym, że za chwilę w ogóle nie wyśle się żadnego maila, bo administratorzy serwerów pocztowych zablokują je totalnie. Będą mogli pisać sami do siebie. A na koniec w ogóle wyłączą serwery, bo zawsze jest ryzyko, że jakiś spam przejdzie. A ryzykować nie ma co... :)

Share this post


Link to post
Share on other sites
Dziwne jest tylko to że koledzy maja konta na różnych portalach a data jest zbieżna. Może to firma na której stoi astroforum ogranicza? Ale wtedy to by chyba wszystkie powiadomienia cięło a nie tylko niektórym użytkownikom.

Ja napisałem do o2.pl w tej sprawie i jestem ciekawy co oni powiedzą.

 

Idea maila na astroforum jest kusząca ale skoro do tej pory było ok to trzeba walczyć aby ten stan powrócił.

ps. dzis dostałem powiadomienie z subskrypcji z 05.07 ciekawe że z takim opóźnieniem dotarło

Sprawdziłem w logach, jaki komunikat wraca po wysłaniu maila automatycznego z AF na twoje konto O2. Moje przypuszczenia były prawidłowe. Chłopaki kombinują... i blokują pocztę - np. z AF ustawiając ją, jako SPAM.

 

Jul 6 04:08:26 1080 qmail: 1215310106.724040 starting delivery 4351: msg 5296794 to remote ******@o2.pl

Jul 6 04:08:26 1080 qmail: 1215310106.724074 status: local 0/5 remote 1/20

Jul 6 04:08:26 1080 qmail: 1215310106.766296 msg: 5296794,delivery 4351: deferral: Connected_to_193.17.41.46_but_sender_was_rejected./Remote_host_said:_/_Zdalny_host_odpowiedzial:_450_Sender_address_rejected

 

Wykropkowałem adres twojego maila z loga, ale generalnie to mail do ciebie od AF (powiadomienie z dzisiaj). Pragnę zwrócić uwagę, że ODRZUCONY ZOSTAŁ WYSYŁAJĄCY, CZYLI AF.

 

Wg mnie, działa to bardzo prosto, jeżeli system pocztowy O2, WP, czy onet wyczai, że mailer to automat, odrzuca go, w razie czego tłumacząc, że AF to serwer SPAMOWy i robią to, żeby ciebie chronić. W nagłówku każdej wiadomości wysłanej z serwera jest coś takiego:

 

X-Mailer: IPB PHP Mailer

 

I prawdopodobnie te wiadomości są odrzucane - tzn. nawet nie wchodzą na serwer O2, ograniczając w ten sposób ruch wewnątrz (serwery, powierzchnie dyskowe, etc.).

 

Oznacza to, że poczta od nas wychodzi prawidłowo. Ja nic nie jestem w stanie już więcej zrobić. Nie sądzę także, abyś sam był w stanie zmusić O2 do odblokowania poczty z AF.

 

Jedynie co ci mogę doradzić, to zaprzestać korzystania z darmowych skrzynek.

Share this post


Link to post
Share on other sites

Przyszła mi jeszcze jedna rzecz do głowy, czy w O2 nie ma czegoś takiego jak White List - czyli możliwość dopisania domeny z której chcesz dostawać maile - tzn. żeby nie były odcinane. Choć nie wiem, czy to czasem nie działa na pocztę, która już weszła na serwer i dopiero dalej jest filtrowana AntySpamem.

 

Generalnie problem nie jest nowy. Poczytałem w necie i fora mają takie problemy. Nic nowego... Polecają przejść na GMaila (z darmowych rozwiązań). Najgorszy pod tym względem jest właśnie O2.

Share this post


Link to post
Share on other sites

Dzięki Adamie za czas poświęcony na dochodzenie - wynika że tak to właśnie wygląda.

 

Pan z Tlenu odpisał mi w ten sposób: "Mam informację z działu technicznego, że konta po stronie Portalu o2.pl działają prawidłowo. Proszę się dowiedzieć czy nadawca posiada revDNS prawidłowo ustawiony."

 

Tlen robi jakieś zmiany na serwerach więc pewnie brak info z AF jest ich wynikiem.

 

ps. zadałem im następne pytanie, ciekawe jak odpowiedzą :D

Edited by mario2005

Share this post


Link to post
Share on other sites
Wg mnie, działa to bardzo prosto, jeżeli system pocztowy O2, WP, czy onet wyczai, że mailer to automat, odrzuca go, w razie czego tłumacząc, że AF to serwer SPAMOWy i robią to, żeby ciebie chronić. W nagłówku każdej wiadomości wysłanej z serwera jest coś takiego:

X-Mailer: IPB PHP Mailer

Posiadam komercyjne konto na serwery.pl. Od pewnego czasu rowniez nie dostaje powiadomien A-F.org. Wyslalem na ten adres wiadomosc z "zakazanym" naglowkiem, doszla bez problemu.

 

Return-Path: <costam>

Received: from smtp.astrohobby.pl (v1281.rev.tld.pl [195.149.228.81])

by astronomia.serwery.pl (8.13.8/8.13.8) with ESMTP id m66GlJGr010420

for <konto wpisane w profilu A-F>; Sun, 6 Jul 2008 18:47:19 +0200

Received: (qmail 27041 invoked by uid 1281029); 6 Jul 2008 16:47:17 -0000

Date: 6 Jul 2008 16:47:17 -0000

[...]

Subject: test

[...]

X-Mailer: IPB PHP Mailer

X-Spam-Status: No, score=2.695 tagged_above=-10 required=5.3

tests=[FH_FROMEML_NOTLD=2.196, FROM_NO_USER=0.499]

X-Spam-Level: **

X-Spam-Score: 2.695

X-Spam-Flag: NO

X-Virus-Scanned: by amavisd-new using ClamAV (N2)

 

Przypuszczam, ze to jednak revDNSy...

 

EDIT

Kolejny test - ta wiadomosc doszla...

 

Return-Path: <>

Received: from smtp.astro-forum.org (v1080.rev.tld.pl [195.149.227.180])

by astronomia.serwery.pl (8.13.8/8.13.8) with ESMTP id m66H4t4J028150

for <>; Sun, 6 Jul 2008 19:04:56 +0200

Received: (qmail 17492 invoked by uid 1080021); 6 Jul 2008 17:04:54 -0000

Date: 6 Jul 2008 17:04:54 -0000

Message-ID: <20080706170454.17491.qmail@smtp.astro-forum.org>

To:

Subject: dojdzie ( Astro-Forum.org )

[...]

From: "Astro-Forum.org" <>

X-Priority: 3

X-Mailer: IPB PHP Mailer

X-Spam-Status: No, score=1.5 tagged_above=-10 required=5.3 tests=[ASNSMX=1.5]

X-Spam-Level: *

X-Spam-Score: 1.5

X-Spam-Flag: NO

X-Virus-Scanned: by amavisd-new using ClamAV (N3)

 

 

Witaj r.ziomber,

 

 

 

r.ziomber wysłał tego email'a z http://astro-forum.org/Forum/index.php.

 

 

 

ten mail?

 

 

---------------------------------------------------

 

Zauważ, że Astro-Forum.org nie ma wpływu na treść tej wiadomości. Pozdrowienia,

 

 

Aha - wiadomosci uznane za spam otrzymuje (tylko w topicu pojawia sie prefix ***SPAM***).

Edited by r.ziomber

Share this post


Link to post
Share on other sites

To z loga odnośnie twoich powiadomień:

 

Jul 6 14:37:30 1080 qmail: 1215347850.189209 starting delivery 5031: msg 5296563 to remote r.ziomber@********.pl

Jul 6 14:37:30 1080 qmail: 1215347850.189235 status: local 1/5 remote 1/20

Jul 6 14:37:30 1080 qmail: 1215347850.191063 msg: 5296563,delivery 5030: success: did_0+0+0/

Jul 6 14:37:30 1080 qmail: 1215347850.191144 status: local 0/5 remote 1/20

Jul 6 14:37:30 1080 qmail: 1215347850.474919 msg: 5296563,delivery 5031: failure: Connected_to_85.128.138.159_but_sender_was_rejected./Remote_host_said:_/_Zdalny_host_odpowiedzial:_553_5.1.8_Domain_of_sender_address_does_not_exist/

 

Dziwne są te komunikaty. Coś przestaje to rozumieć. Siedzę nad tymi logami już dłuższą chwilę i nic mi nie przychodzi do głowy.

Share this post


Link to post
Share on other sites
Guest polaris

Zmieniłem aktywny adres mail na AF i dzięki Radkowi (r.ziomber) przetestowałem powiadomienie.

Zadziałało. Powiadomienie doszło błyskawicznie - domyślnie oznaczone zostało jako *SPAM*, ale bez problemu przeszło przez serwer na skrzynkę.

Edited by polaris

Share this post


Link to post
Share on other sites
Jul 6 14:37:30 1080 qmail: 1215347850.474919 msg: 5296563,delivery 5031: failure: Connected_to_85.128.138.159_but_sender_was_rejected./Remote_host_said:_/_Zdalny_host_odpowiedzial:_553_5.1.8_Domain_of_sender_address_does_not_exist/
revDNS chyba jednak...

Share this post


Link to post
Share on other sites

BINGO. Chyba odkryłem przyczynę, dlaczego niektóre serwery pocztowe zaczęły ciąć pocztę z AF. W czasach jak zakładałem forum używałem konta firmowego i takie też było wpisane podczas instalacji - jako tzw. return path. W między czasie nazwa firmy się zmieniła (lata temu), a wpis w konfiguracji pozostał. Na początku czerwca wyexpirowała się domena naszej poprzedniej nazwy i przestała istnieć.

 

Oznacza to, że niektóre serwery pocztowe sprawdzały pole RETURN PATH (nie chodziło o sendera) i stwierdzały, że wpisana jest domena, która nie istnieje. Stąd traktowały to, jako podejrzany syf z netu.

 

Najgorsze jest jednak to, że nie mogę w systemie zmienić tego maila. Kupiłem tę domenę przed chwilą, założę na niej ten sam mail i jutro-pojutrze wszystko powinno zadziałać.

 

Dziękuję Wam za inwigilację. Dzięki temu udało się dojść do tego dość zaskakującego wniosku.

 

revDNS chyba jednak...

Nie, czytaj wyżej. Nie chodzi o Astro-Forum.org domenę, a drugą, która pojawiała się w nagłówkach poczty.

Share this post


Link to post
Share on other sites

Sorry Radek, niechcący wrzuciłem z logów twojego maila. Już usunąłem - mam nadzieję, że żaden harvester nie zdążył go pożreć ;)

Share this post


Link to post
Share on other sites
Oznacza to, że niektóre serwery pocztowe sprawdzały pole RETURN PATH (nie chodziło o sendera) i stwierdzały, że wpisana jest domena, która nie istnieje. Stąd traktowały to, jako podejrzany syf z netu.

Najgorsze jest jednak to, że nie mogę w systemie zmienić tego maila.

Z czystej ciekawosci (jesli to nie jest tajne ;-): czyzby kwestie licencji/zabezpieczen "antypirackich" IPB byly az tak restrykcyjne?
Sorry Radek, niechcący wrzuciłem z logów twojego maila. Już usunąłem - mam nadzieję, że żaden harvester nie zdążył go pożreć ;)
Nie ma sprawy :) Dzieki za szybka reakcje. Edited by r.ziomber

Share this post


Link to post
Share on other sites
Z czystej ciekawosci (jesli to nie jest tajne ;-): czyzby kwestie licencji/zabezpieczen "antypirackich" IPB byly az tak restrykcyjne?

 

Nie sądze, chyba bug jakiś. Coś jest nie tak, ale szczerze mówiąc, nie chce mi się siedzieć i tego dochodzić. Może po update softu zadziała, bo u nas już leciwa wersja.

Share this post


Link to post
Share on other sites

Przed chwila otrzymalem e-mail:

[...]

Subject: Powiadomienie o odpowiedzi w subskrybowanym temacie ( Astro-Forum.org )

[...]

;-)

Share this post


Link to post
Share on other sites
Przed chwila otrzymalem e-mail:

[...]

Subject: Powiadomienie o odpowiedzi w subskrybowanym temacie ( Astro-Forum.org )

[...]

;-)

Udało się zmienić ten mail bezpośrednio w bazie - nie przez CMS. Działa :) Jesteśmy uratowani... znowu nie było spisku przeciwko AF. A już miałem nadzieję.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.