Jump to content

Astroberry Server


Recommended Posts

22 godziny temu, RadekK napisał:

... nie jest w grupie gpio to dodaj go, przeloguj użytkownika i ciesz się focuserem ;-)


sudo usermod -a -G gpio astroberry

 

Dzięki!. Dodanie użytkownika stellarmate do grupy gpio pomogło. Czy ten sterownik nie może być domyślnie w indi ?. Często jak zaktualizuje system to muszę go ponownie pobierać i kompilować. Nie byłoby to uciążliwe gdyby nie to, że dość często wychodzą jakieś problemy. Przykładowo po zmianie na RPI4 nie pasowała wersja biblioteki itp. Super, że można piny samemu definiować poza kodem, bo zawsze musiałem zmieniać na swoje. Poprzednie kolidowały mi z RTC.

7 godzin temu, mirek01 napisał:

Tak.sterownik focusera jest coraz przyjemniejszy. Z kompensacją temp. będzie bajka:D

 

A skoro będzie już czujnik temp. To można pokusić się o włącznik grzałek  (wykorzystując  kanał Astrobery Board) a nawet sterowanie grzałkami w zależności od temp.  

 

Jakieś plany?

 

M.

Potrzebny jest raczej czujnik wilgotności. U mnie zajmuje się tym Arduino. Początkowo liczyłem punkt rosy itp, ale praktyczne podejście to zacząć grzać jak wilgotność w odrośniku osiągnie poziom xx.

Mam 2 pytania:

1. Jak ten czujnik temperatury się kalibruje w indi ?.

2. Co wpisać aby było pokazane critical focus zone ?. (podałem max traveel oraz wpisałem teleskop)

 

Edited by rambro
Link to post
Share on other sites

Teoretycznie sterownik mógłby być w INDI, ale na razie nie jest. Pomyślę czy tak chcę ;)

 

42 minutes ago, rambro said:

1. Jak ten czujnik temperatury się kalibruje w indi ?.

Obecnie podaje się współczynnik rozszerzalności temperaturowej materiału z jakiego jest zrobiona tuba (Temperature Coefficient w μm/m°C)

 

44 minutes ago, rambro said:

2. Co wpisać aby było pokazane critical focus zone ?

Musisz podać ogniskową i aperturę w konfiguracji teleskopu - albo na zakładce Mount w Ekos albo w opcjach panelu INDI sterownika

Link to post
Share on other sites
  • 2 weeks later...

Dyskusja o podłączaniu GPSa do Astroberry spowodowała, że wygrzebałem z otchłani wiekowy moduł GPS TomTom na BT, który pewnie ma ponad 10 lat. Po intensywnym czytaniu różnych forów udało mi się to cudo uruchomić i mam GPSa widzianego przez Rp 4 i przez  kStars na wszystkich podłączonych do Rp platformach (równolegle) tj. macOS, Win10 i Ubuntu. Mała rzecz a cieszy. 

  • Like 2
Link to post
Share on other sites
Godzinę temu, apolkowski napisał:

Po intensywnym czytaniu różnych forów udało mi się to cudo uruchomić i mam GPSa widzianego przez Rp 4 i przez  kStars na wszystkich 

Brawo Ty:D

Napisz o co i gdzie pomanipulowałeś, będzie dla innych. 

Moze cos podpatrzę, u mnie nie widzi modułu  GPS nawet na porcie szeregowym  

Link to post
Share on other sites

Działa to tak.

 

Krok 1 - sparowałem moduł używając ikonki BT na górnym pasku sterowania Astroberry

Krok 2 - sudo rfcomm bind /dev/rfcomm0 xx:xx:xx:xx:xx:xx gdzie iksy to adres modułu

Krok 3 - komenda sudo killall gpsd   "ubija" wszystkie ewentualne aktywne instancje gpsd

Krok 4 - komenda sudo gpsd /dev/rfcomm0 -F /var/run/gpsd.sock uruchamia gpsd powiązane z portem modułu

Krok 5 - komenda sudo systemctl stop gpdpanel.service zatrzymuje aktywny proces gpspanel

Krok 6 - komenda sudo systemctl start gpspanel.service uruchamia ponownie proces gpspanel

 

Kroku 1 nie muszę powtarzać po restarcie. Po pierwszym sparowaniu moduł jest parowany automatycznie.

Kroki 2 - 6 mam zapisane w wykonywalnym skrypcie, który uruchamiam ręcznie po starcie systemu.

Bez kroków 5 - 6 Panel GPS nie odczytywał sygnału z GPSD mimo, że kStars i cgps dane odbierały. Można bez tego działać, ale zrobiłem dla porządku.

Wpisanie portu modułu do pliku konfiguracji gpsd nic mi nie dawało.

 

To tyle. Efekt prób i błędów, a nie wiedzy. Ale działa.

  

  • Like 1
Link to post
Share on other sites
  • 3 weeks later...

Astroberry Server 1.1 to dosyć stara wersja systemu, której już nie aktualizuję. Wersja 1.1 zbudowana jest na bazie Ubuntu Mate 16.04 z 2016 r. a więc ma już 4 lata... a libgpio zostało dodane do jądra linuxa... 3 lata temu. Sprawdziłem na szybko i w repozytorium 16.04 nie ma pakietu libgpio i biorąc pod uwagę to, że wsparcie dla wersji 16.04 skończyło się w tym roku wraz z wydaniem 20.04 to nie sądzę, żeby było dodane. Co więcej nie sądzę, żeby było wspierane przez wersję kernela/jądra który masz zainstalowany.

Jedyne co mogę doradzić to przesiadka na nową wersję Astroberry Server dostępną na stronie https://www.astroberry.io

Jeśli jednak postanowisz zostać przy wersji 1.1 to możesz poeksperymentować i dodać ręcznie libgpio korzystając ze źródeł https://git.kernel.org/pub/scm/libs/libgpiod/libgpiod.git/refs/tags

 

  • Like 1
Link to post
Share on other sites
  • 2 months later...

Hej mam pytanie, nabyłem Raspberry Pi 4 model B, mam na nim Astroberry Server 2.0.3. Przy łączeniu się z heq5 po bluetooth łączy się, ale jest coś takiego:

No usable services on this device. INDI oczywiście nie widzi montażu. W Windowsie żeby to działało musiałem chyba wirtualny port COM isnatlować czy coś takiego. Zadziała to na malince po bluetooth?

Zrzut ekranu 2020-08-24 o 18.59.39.png

Link to post
Share on other sites
Godzinę temu, isset napisał:

Hej mam pytanie, nabyłem Raspberry Pi 4 model B, mam na nim Astroberry Server 2.0.3. Przy łączeniu się z heq5 po bluetooth łączy się, ale jest coś takiego:

No usable services on this device. INDI oczywiście nie widzi montażu. W Windowsie żeby to działało musiałem chyba wirtualny port COM isnatlować czy coś takiego. Zadziała to na malince po bluetooth?

Zrzut ekranu 2020-08-24 o 18.59.39.png

A wipsywałeś w terminal ? sprawdź czy zadziała komenda, musisz zainstalować jakieś narzędzie obsługi bluetooth.

sudo bluetoothctl

 

https://www.cnet.com/how-to/how-to-setup-bluetooth-on-a-raspberry-pi-3/

 

Edited by Selmak
  • Thanks 1
Link to post
Share on other sites
2 godziny temu, isset napisał:

 Astroberry Server 2.0.3. Przy łączeniu się z heq5 

Sorry ... że to nie odpowiedź na pytanie

Ale czy nie lepiej Ci bedzię łączyć malinę z montażem kabelkiem?

M.

Link to post
Share on other sites
1 minutę temu, mirek01 napisał:

Ale czy nie lepiej Ci bedzię łączyć malinę z montażem kabelkiem?

Może i lepiej, ale nie lubię, jak mnie coś ogranicza. Skoro malinka ma bluetooth to czemu nie skorzystać :) 

Link to post
Share on other sites
1 godzinę temu, Selmak napisał:

A wipsywałeś w terminal ? sprawdź czy zadziała komenda, musisz zainstalować jakieś narzędzie obsługi bluetooth.

sudo bluetoothctl

Agent registered
[bluetooth]# 

[CHG] Device D4:11:A3:B0:0A:9A Connected: yes
[CHG] Device D4:11:A3:B0:0A:9A Modalias: bluetooth:v0075p0100d0201
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 00001105-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 0000110a-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 00001112-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 00001115-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 00001116-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 0000111f-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 0000112d-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 0000112f-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 00001132-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 00001800-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 00001801-0000-1000-8000-00805f9b34fb
[CHG] Device D4:11:A3:B0:0A:9A UUIDs: 7c7bcc5e-27a2-11e9-ab14-d663bd873d93
[CHG] Device D4:11:A3:B0:0A:9A ServicesResolved: yes
[CHG] Device D4:11:A3:B0:0A:9A Paired: yes
[CHG] Device D4:11:A3:B0:0A:9A Trusted: yes
[CHG] Device D4:11:A3:B0:0A:9A ServicesResolved: no
[CHG] Device D4:11:A3:B0:0A:9A Connected: no

Link to post
Share on other sites
13 minut temu, apolkowski napisał:

Wyżej masz mój post dot. GPSa na BT i w nim komendę przypisywania portu do połączenia BT

Tak zrobiłem, ale nadal nic :( Jak się nie uda, to przejdę na kabel, ale to będzie słabe ze strony malinki, że tak prosta czynność jak połączenie bluetooth i już wysiada.

Zrzut ekranu 2020-08-25 o 11.46.38.png

Link to post
Share on other sites
41 minut temu, wylam napisał:

u mnie zadziałał sposób z linka poniżej/

Wow, pomogło!! :) Dziękuję :) 

 

Po reboocie wszystkiego już sam się połączył po bluetooth z montażem, i o to chodziło.

Zrzut ekranu 2020-08-25 o 12.37.24.png

Edited by isset
  • Like 1
Link to post
Share on other sites

Jeszcze tych portów nie ogarniam. W Windowsie wchodzisz do managera urządzeń i widzisz, aha focuser na porcie 4, a montaż na 14 i wszystko jasne i tak podajesz w konfiguracji, a tutaj póki co jak dziecko we mgle :) 

 

Skrót jak to zadziałało u mnie, może się komuś przyda:

 

Wchodzimy do bluetooth:
sudo bluetoothctl

 

Odpalamy skanowanie sieci:
scan on

 

Znajdujemy nasze urządzenie i kopiujemy jego adres: XX:XX:XX:XX:XX

Parujemy:
pair XX:XX:XX:XX:XX

 

Podajemy hasło: xxxx

 

Obdarzamy zaufaniem:
trust XX:XX:XX:XX:XX

 

Wychodzimy:
exit

 

Następnie edycja pliku bluetooth.service:
sudo nano /etc/systemd/system/bluetooth.target.wants/bluetooth.service

 

Za linijką: ExecStart=/usr/lib/bluetooth/bluetoothd dodajemy:
ExecStartPost=/usr/bin/rfcomm bind rfcomm0 XX:XX:XX:XX:XX

 

Zapisujemy plik, wychodzimy, restart malinki.

Edited by isset
Link to post
Share on other sites

Kolejne pytanie, udało mi się zmusić do pracy HEQ5 (po bluetooth), dreamfocuser oraz kamerę QHY9. Mam problem z kołem filtrowym QHYCFW2S połączone po USB. INDI łączy się z kołem, widzi, że jest 5 pozycyjne, ale nie zmienia filtrów. Drugi problem to kamera do guidingu chińska T7, tzw. klon ASI120. Tak samo INDI łączy się, czyta rozmiar piksela oraz temperaturę matrycy, ale jak próbuję zapętlić obraz w PHD2, to wyskakuje taki żółty komunikat, że po 18 sekundach oczekiwania nie udało się wykonać klatki.

Link to post
Share on other sites
55 minut temu, isset napisał:

Kolejne pytanie, udało mi się zmusić do pracy HEQ5 (po bluetooth), dreamfocuser oraz kamerę QHY9. Mam problem z kołem filtrowym QHYCFW2S połączone po USB. INDI łączy się z kołem, widzi, że jest 5 pozycyjne, ale nie zmienia filtrów. Drugi problem to kamera do guidingu chińska T7, tzw. klon ASI120. Tak samo INDI łączy się, czyta rozmiar piksela oraz temperaturę matrycy, ale jak próbuję zapętlić obraz w PHD2, to wyskakuje taki żółty komunikat, że po 18 sekundach oczekiwania nie udało się wykonać klatki.

Jeśli nie powstała jakaś alternatywa dla użytkowania T7 z Indi to nie będziesz mógł jej używać. MI też nie działało i wielu innym.

Zobaczymy co powiedzą inni.

Kiedyś zmieniało się frimewire kamerki w tryb kompatybilny, ale dzisiaj to nie przynosi różnicy.

Sterowniki INDI współpracują bezproblemowo z kamerami ZWO tylko tymi które mają na wyposażeniu USB 3.0.

W starszych ZWO z usb 2.0 zmieniało się frimeware i wtedy działało.

Edited by Selmak
Link to post
Share on other sites
1 godzinę temu, isset napisał:

Drugi problem to kamera do guidingu chińska T7, tzw. klon ASI120. Tak samo INDI łączy się, czyta rozmiar piksela oraz temperaturę matrycy, ale jak próbuję zapętlić obraz w PHD2, to wyskakuje taki żółty komunikat, że po 18 sekundach oczekiwania nie udało się wykonać klatki.

Możesz ewentualnie sprawdzić czy T7 zadziała z modułem guidingu wbudowanym w Kstars. U mnie działa, ale na macOS. Na Astroberry nie próbowałem. Może mi się uda sprawdzić w weekend.

Czy jak zmienisz w Kstars w module foto kamerę na T7, to możesz zrobić zdjęcie?

Link to post
Share on other sites
9 minut temu, apolkowski napisał:

Czy jak zmienisz w Kstars w module foto kamerę na T7, to możesz zrobić zdjęcie?

Nawet nie wiem, w Kstars nie próbowałem, dziś spróbuję.

Link to post
Share on other sites
3 godziny temu, isset napisał:

Kolejne pytanie, udało mi się zmusić do pracy HEQ5 (po bluetooth), dreamfocuser oraz kamerę QHY9. Mam problem z kołem filtrowym QHYCFW2S połączone po USB. INDI łączy się z kołem, widzi, że jest 5 pozycyjne, ale nie zmienia filtrów. Drugi problem to kamera do guidingu chińska T7, tzw. klon ASI120. Tak samo INDI łączy się, czyta rozmiar piksela oraz temperaturę matrycy, ale jak próbuję zapętlić obraz w PHD2, to wyskakuje taki żółty komunikat, że po 18 sekundach oczekiwania nie udało się wykonać klatki.

Nie odpalają sterowników zwo w INDI. Phd ma swoje sterowniki dla ZWO.

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Our picks

    • Jeśli coś jest głupie, ale działa, to nie jest głupie - o nietypowych rozwiązaniach sprzętowych
      Sformułowanie, które można znaleźć w internetach jako jedno z "praw Murphy'ego" przyszło mi na myśl, gdy kolejny raz przeglądałem zdjęcia na telefonie z ostatniego zlotu, mając z tyłu głowy najgłośniejszy marsjański temat na forum. Do rzeczy - jakie macie (bardzo) nietypowe patenty na usprawnienie sprzętu astronomicznego bądź jakieś kreatywne improwizacje w razie awarii czy niezabrania jakiegoś elementu sprzętu  Obstawiam, że @HAMAL mógłby samodzielnie wypełnić treścią taki wątek.
        • Haha
        • Like
      • 21 replies
    • MARS 2020 - mapa albedo powierzchni + pełny obrót 3D  (tutorial gratis)
      Dzisiejszej nocy mamy opozycję Marsa więc to chyba dobry moment żeby zaprezentować wyniki mojego wrześniowego projektu. Pogody ostatnio jak na lekarstwo – od początku października praktycznie nie udało mi się fotografować. Na szczęście wrzesień dopisał jeśli chodzi o warunki seeingowe i udało mi się skończyć długo planowany projekt pełnej mapy powierzchni (struktur albedo) Marsa.
        • Love
        • Thanks
        • Like
      • 119 replies
    • Aktualizacja silnika Astropolis - zgłaszanie uwag
      Dzisiaj zaktualizowaliśmy silnik Astropolis do najnowszej wersji (głównie z powodów bezpieczeństwa). Najpoważniejsze błędy zostały już naprawione, ale ponieważ aktualizacja jest dosyć rozbudowana (dotyczy także wyglądu), drobnych problemów na pewno jest więcej. Bez was ich nie namierzymy. Dlatego bardzo proszę o pomoc i wrzucanie tu informacji o napotkanych problemach/błędach.
        • Like
      • 236 replies
    • Insight Investment Astrophotographer of the Year 2020 – mój mały-wielki sukces :)
      Jestem raczej osobą która nie lubi się chwalić i przechwalać… ale tym razem jest to wydarzenie dla mnie tak ważne, że postanowiłem podzielić się z Wami tą niezwykle radosną dla mnie wiadomością.
       
      Moja praca zajęła pierwsze miejsce w kategorii „Planety, komety i asteroidy” podczas tegorocznego konkursu Insight Investment Astronomy Photographer of the Year 2020.
        • Love
        • Thanks
        • Like
      • 85 replies
    • Zobaczyć powierzchnię Wenus.... - mapa promieniowania termicznego (sezon 2020)
      Zacznę od zdjęcia a potem będą technikalia, opisy zbierania materiału oraz informacje o obróbce
      6 maja faza Wenus zmalała poniżej 20% więc zaczął się najlepszy okres kiedy możemy podejmować próby rejestracji promieniowania termicznego powierzchni Wenus. Czas ten potrwa mnie więcej 17-18 maja kiedy to planeta będzie już zbyt blisko Słońca i kontrast zmaleje uniemożliwiając (lub utrudniając) rejestrację tego zjawiska.
        • Love
        • Thanks
        • Like
      • 30 replies
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.