Jump to content

Astroberry Server


Guest RadekK
 Share

Recommended Posts

Czy komuś udało się połączyć z Windowsa 10 z Hotspotem astroberry i potem uzyskać połączenie z http://astroberry.local ?

Mój jedyny sukces polegał na jednorazowym połączeniu PC z hotspotem, niestety dalej (za pomocą firefoxa) nie poszło. Po przełączeniu wifi PC do routera internetowego nie udało mi się ponownie połączyć z hotspotem astroberry.

 

Astroberry Server najnowszy, zaktualizowany. Podczas prób Kaspersky wyłączony na wszelki wypadek.

Link to comment
Share on other sites

Z Maca nie ma żadnego problemu. Mogę w kółko przełączać się pomiędzy trzema sieciami, bo mam tak: domowe wifi, wifi własne Raspberry oraz routerek podpiety do Raspberry, bo ta sieć Raspberry jest dosyć słaba. Tylko u mnie na początku malina byla podpięta po hdmi do telewizora i konfigurowałem początkowe ustawienia w ten sposób. 

 

Aha, spróbuj dać https zamiast http :)

 

Edited by isset
Link to comment
Share on other sites

2 godziny temu, bacHor napisał:

Gratuluje decyzji! Zakładam, że druga wersję.

 

pierwszą, drugiej na razie nie ma a nie chciałem czekać

i mam GPSa na USB

Link to comment
Share on other sites

53 minuty temu, dziki napisał:

Czy komuś udało się połączyć z Windowsa 10 z Hotspotem astroberry i potem uzyskać połączenie z http://astroberry.local ?

Mój jedyny sukces polegał na jednorazowym połączeniu PC z hotspotem, niestety dalej (za pomocą firefoxa) nie poszło. Po przełączeniu wifi PC do routera internetowego nie udało mi się ponownie połączyć z hotspotem astroberry.

 

Astroberry Server najnowszy, zaktualizowany. Podczas prób Kaspersky wyłączony na wszelki wypadek.

Też miałem takie problemy na początku. Przeglądanie przez stronę jest niestabilne i też działało mi tylko zaraz po pierwszym uruchomieniu. Ściągnij sobie ten programik: https://www.realvnc.com/en/connect/download/viewer/

I zamiast wchodzić przez stronę, skonfiguruj w nim połączenie.

 

EDIT: Jeśli nie możesz w ogóle się połączyć z hotspotem, to być może to ten sam problem, który ja miałem: https://astropolis.pl/topic/64940-astroberry-server/?do=findComment&comment=934683

 

Edited by holeris
  • Like 1
Link to comment
Share on other sites

Godzinę temu, holeris napisał:

Też miałem takie problemy na początku. Przeglądanie przez stronę jest niestabilne i też działało mi tylko zaraz po pierwszym uruchomieniu. Ściągnij sobie ten programik: https://www.realvnc.com/en/connect/download/viewer/

I zamiast wchodzić przez stronę, skonfiguruj w nim połączenie.

Czy VNC będzie działał po hotspocie? Chodzi mi o to że w terenie nie będę miał dostępu do internetu.

 

52 minuty temu, isset napisał:

Zaraz sprawdzę...

 

edit: nie wierze ze to pisze ale niestety nie mam wirusa

jednak - stawiam system od nowa i próbuję zaimplementować rozwiązanie podlinkowane przez holerisa

Link to comment
Share on other sites

27 minut temu, dziki napisał:

Czy VNC będzie działał po hotspocie? Chodzi mi o to że w terenie nie będę miał dostępu do internetu

Będzie, ja tak działam od początku. Moj setup nie ma połączenia z internetem i dzialam na vnc właśnie. 

  • Like 1
Link to comment
Share on other sites

34 minuty temu, dziki napisał:

Ok. Jak rozłączę malinkę od routera, to jak sprawić żeby hotspot powstał nie restartując malinki?

Chyba będziesz musiał zrestartować mailnę i wtedy zobaczy że nie może się połączyć z innymi zapamiętanymi sieciami i utworzy hotspota automatycznie.

  • Like 1
Link to comment
Share on other sites

Niestety...

 

Zrobiłem wpa_supplicant w wersji 2.9. Tablet podłączył się do hotspota tylko raz (stabilnie). Gdy tablet był podpięty do hotspota, nie udało się nawiązać żadnego połączenia, ani przez przeglądarkę (http i  https://astroberry.local/), ani przez VNC (komunikat w rodzaju że host nieznany).

 

Po przełączeniu Malinki do routera, a potem po restarcie jak powstał hotspot - już nie udało się ponownie podłączyć tableta do hotspota.

 

Z PC: gdy podpinam się do hotspota malinki, VNC daje komunikat: No such host is known (łączę się z astroberry.local:5900)

Z PC: gdy malinka podpieta jest to internetu, VNC działa bez zarzutu.

 

Być może robię jakiś podstawowy noobowy błąd (na linuxie znam sie jak na lotach na Księżyc - wiem, że były ;))

Link to comment
Share on other sites

Godzinę temu, dziki napisał:

Z PC: gdy podpinam się do hotspota malinki, VNC daje komunikat: No such host is known (łączę się z astroberry.local:5900)

Spróbuj wpisać IP maliny zamiast astroberry.local

  • Like 1
Link to comment
Share on other sites

W vnc podaj oczywiście IP Maliny jak pisze kolega wyżej a nie adres www. Ten adres astroberry.local to służy do połączenia się przez przeglądarkę :)

  • Like 1
Link to comment
Share on other sites

I pamiętaj ze Malina ma inny adres IP jak stawia swoj hotspot, a inny jak jest podpięta do Twojego domowego wifi. Ja mam zdefiniowane dwa osobne połączenia w vnc w zależności do czego się łączę. 

  • Like 1
Link to comment
Share on other sites

No to serialu ciąg dalszy...

 

Dla przypomnienia: mam czystą zaktualizowaną instalację Astroberry server, ze zmienionym hasłem do Pi i do wifi, poaktualizowane wszystko co się dało. Jedyne co grzebnąłem to w ustawieniach hotspota w polu "urządzenie" wskazałem "wlan0" - bo było nic.

 

Połączyłem się na chwilę z PC z hotspotem RPI, ale stracił połączenie
Laptop był jakieś 2-3 metry od RPI, słyszałem że hotspot RPI jest mega słaby. Przeniosłem laptopa niecały metr od malinki.
Komunikat po próbie połączenia: "Zabezpieczone. Nie można połączyć się z tą siecią".

Hotspot astoberry przestaje pojawiać się w dostępnych sieciach na PC.

 

Restart malinki.
Jest!

 

Połączone.

 

IP PC: 10.42.0.245
IP RPI: 10.42.0.1

 

Próba połączenia z VNC viewer z PC (VNC server: 10.42.0.1:5900)

Komunikat: Timed out waiting for a response from the computer

 

ping z PC do 10.42.0.1: request timed out
ping z RPI do 10.42.0.245 destination host unreachable

Czasowo wyłączyłem Kaspersky, zresztą astroberry figuruje jako sieć zaufana.

 

Wygląda jakby kompy się nie widziały. Houston...

 

Tablet niestety połączył się raz, wczoraj. Dzisiaj niestety nie dochodzi do połączenia z hotspotem :(

 

Edit: właśnie osiągnąłem pierwszy sukces! :) Zrestartowałem tableta, połączył się z hotspotem i zadziałał VNC oczywiście po adresie IP. Dzięki wszystkim za pomoc :)

 

... to teraz jeszcze zagadka czemu PC nie widzi RPI ;)

Link to comment
Share on other sites

14 minut temu, isset napisał:

Jak dla mnie to dziwne są te Twoje IP. Nie powinno być coś w stylu 192.168....?

Ten adres IP też jest z puli adresów prywatnych:

 

Range from 10.0.0.0 to 10.255.255.255 — a 10.0.0.0 network with a 255.0.0.0 or /8 (an 8-bit) mask

Range from 172.16.0.0 to 172.31.255.255 — a 172.16.0.0 network with a 255.240.0.0 or /12

A 192.168.0.0 to 192.168.255.255 range, which is a 192.168.0.0 network masked by 255.255.0.0 or /16

A special range 100.64.0.0 to 100.127.255.255 with a 255.192.0.0 or /10 network mask; this subnet is recommended according to rfc6598 for use as an address pool for CGN (Carrier-Grade NAT)

Link to comment
Share on other sites

No dobra, czyli oba kompy (RPI i PC) dostają adresy z tej samej puli prywatnej, więc wygląda że jest OK.

Tylko się nie widzą, nie mogą sie spingować :g:

 

edit: oczywiście pozostaje spięcie PC i RPI po kablu ethernetowym, czytałem że wymaga to paru dodatkowych akcji ale powinno zadziałać.

Link to comment
Share on other sites

Podłączam właśnie zegar czasu rzeczywistego do RPI, jak się nie zjara to działamy dalej ;)

 

astroberry@astroberry:~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether e4:5f:01:4a:24:f2 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether e4:5f:01:4a:24:f3 brd ff:ff:ff:ff:ff:ff
    inet 10.42.0.1/24 brd 10.42.0.255 scope global noprefixroute wlan0
       valid_lft forever preferred_lft forever
    inet 169.254.239.81/16 brd 169.254.255.255 scope global noprefixroute wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::5684:2699:ab8c:1337/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::3cf5:2af5:8bb:3f29/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
astroberry@astroberry:~ $ ip r sh
default dev wlan0 scope link src 169.254.239.81 metric 303
10.42.0.0/24 dev wlan0 proto kernel scope link src 10.42.0.1 metric 600
169.254.0.0/16 dev wlan0 scope link src 169.254.239.81 metric 303
astroberry@astroberry:~ $ ip r get 10.42.0.245
10.42.0.245 dev wlan0 src 10.42.0.1 uid 1001
    cache
astroberry@astroberry:~ $

 

Link to comment
Share on other sites

3 godziny temu, lkosz napisał:

i rozumiem, że laptop na windowsie jest podłączony bezpośrednio pod accesspoint na raspberry? Nie przestawiałeś raspberry żeby łączył się z siecią domową?

Przestawiałem - RPI łączył się z siecią domową, dostawał IP z puli 192.168... i wtedy mogłem się łączyć się przez VNC z laptopa. Natomiast wcześniejsze próby robiłem jak był aktywny hotspot.

 

Dla upewnienia się przed chwilą zrobiłem próby jeszcze raz: po restarcie RPI wstał hotspot, IP 10.42.0.1  (na 100%, mam obraz z RPI na TV). Laptop... nie podłączył się do hotspotu astroberry, nazwa sieci zniknęła z listy sieci wifi. Zrestartowałem laptopa, zrestartowałem RPI, brak widoczności astroberry (mimo że na RPI hotspot działa). Ponowny restart obu urządzeń. I...

 

nie rozumiem co się stało: laptopem podłączyłem się do astroberry, tak jak poprzednio dostał 10.42.0.245, oba urządzenia się pingują i działa połączenie po VNC!!

NIC nie zrobiłem od wczoraj, poza dodaniem modułu czasu rzeczywistego. Kompletnie nie rozumiem co się zadziało (co specjalnie nie dziwi bo na linuxie znam się jak świnia na lotach w kosmos)

  • Haha 1
Link to comment
Share on other sites

3 godziny temu, dziki napisał:

NIC nie zrobiłem od wczoraj, poza dodaniem modułu czasu rzeczywistego. Kompletnie nie rozumiem co się zadziało (co specjalnie nie dziwi bo na linuxie znam się jak świnia na lotach w kosmos)

zły routing po stronie laptopa, krzywe ARPy albo syf na firewallu

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Our picks

    • Droga Mleczna w dwóch gigapikselach
      Zdjęcie jest mozaiką 110 kadrów, każdy po 4 minuty ekspozycji na ISO 400. Wykorzystałem dwa teleskopy Takahashi Epsilon 130D i dwa aparaty Nikon D810A zamocowane na montażu Losmandy G11 wynajętym na miejscu. Teleskopy były ustawione względem siebie pod lekkim kątem, aby umożliwić fotografowanie dwóch fragmentów mozaiki za jednym razem.
        • Love
        • Thanks
        • Like
      • 44 replies
    • Przelot ISS z ogniskowej 2350 mm
      Cześć, po kilku podejściach w końcu udało mi się odpowiednio przygotować cały sprzęt i nadążyć za ISS bez stracenia jej ani razu z pola widzenia. Wykorzystałem do tego montaż Rainbow RST-135, który posiada sprzętową możliwość śledzenia satelitów.
      Celestron Edge 9,25" + ZWO ASI183MM. Czas ekspozycji 6 ms na klatkę, końcowy film składa się z grup 40 klatek stackowanych, wyostrzanych i powiększonych 250%.
      W przyszłości chciałbym wrócić do tematu z kamerką ASI174MM, która z barlowem 2x da mi podobną skalę, ale 5-6 razy większą liczbę klatek na sekundę.
      Poniżej film z przelotu, na dole najlepsza klatka.
        • Love
        • Thanks
        • Like
      • 70 replies
    • Big Bang remnant - Ursa Major Arc or UMa Arc
      Tytuł nieco przekorny bo nie chodzi tu oczywiście o Wielki Wybuch ale ... zacznijmy od początku.
       
      W roku 1997 Peter McCullough używając eksperymentalnej kamery nagrał w paśmie Ha długą na 2 stopnie prostą linie przecinajacą niebo.
       
      Peter McCullough na konferencji pokazał fotografię Robertowi Benjamin i obaj byli pod wrażeniem - padło nawet stwierdzenie: “In astronomy, you never see perfectly straight lines in the sky,”
        • Love
        • Thanks
        • Like
      • 16 replies
    • Jeśli coś jest głupie, ale działa, to nie jest głupie - o nietypowych rozwiązaniach sprzętowych
      Sformułowanie, które można znaleźć w internetach jako jedno z "praw Murphy'ego" przyszło mi na myśl, gdy kolejny raz przeglądałem zdjęcia na telefonie z ostatniego zlotu, mając z tyłu głowy najgłośniejszy marsjański temat na forum. Do rzeczy - jakie macie (bardzo) nietypowe patenty na usprawnienie sprzętu astronomicznego bądź jakieś kreatywne improwizacje w razie awarii czy niezabrania jakiegoś elementu sprzętu  Obstawiam, że @HAMAL mógłby samodzielnie wypełnić treścią taki wątek.
        • Haha
        • Like
      • 43 replies
    • MARS 2020 - mapa albedo powierzchni + pełny obrót 3D  (tutorial gratis)
      Dzisiejszej nocy mamy opozycję Marsa więc to chyba dobry moment żeby zaprezentować wyniki mojego wrześniowego projektu. Pogody ostatnio jak na lekarstwo – od początku października praktycznie nie udało mi się fotografować. Na szczęście wrzesień dopisał jeśli chodzi o warunki seeingowe i udało mi się skończyć długo planowany projekt pełnej mapy powierzchni (struktur albedo) Marsa.
        • Love
        • Thanks
        • Like
      • 132 replies
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.