Jump to content

Recommended Posts

Cześć

 

chciałem zapytać o Wasze doświadczenia oraz ewentualne rozwiązania problemów związanych z USB.

Z racji dużej ilości kabli USB korzystam z huba USB3 zasilanego 5V.

W zasadzie za każdym razem gdy podłączam sprzęt mam  taki taniec

kamera nie pójdzie z huba tylko bezpośrednio do kompa

za godzinę słyszę, że się coś rozłączyło to mont i musze go wpiąć bezpośrednio do kompa, ale nie mam miejsc więc daję kamerę na huba i tym razem idzie

itd itp

wkładam wtyczki do gniazd - nie działa, nie działa, działa, zaraz nie działa i znowu działa. a juto jest na odwrót, w tym co działało nie działa.

 

Mógłbym podejrzewać huba, ale jak napisałem czasami jest to w drugą stronę. Poza tym to samo dotyczy samych gniazdek w kompie. Urządzenia nie są rozpoznawane (80%) lub są odłączane. Wczoraj po godzinie pracy ASA odłączyła USB i co 3 minuty zrywała połączenie i zwinąłem się bo mnie szlag trafił

 

Sprawa dotyczy bardzo różnych sprzętów na różnych kompach. Kabli setka, dobre, słabsze, nowe stare itd.  Wszędzie to samo.

Jednej nocy bajka, innej przekładam kable co kwadrans.

 

Chciałbym wetknąć wszystko do zasilanego koncentratora i przez jeden kabel podłączyć to do lapka. Na razie nici z tego pomysłu.

 

Macie tak?

Co robicie?

Edited by kubaman
Link to post
Share on other sites

Znam to, nawet wczoraj musiałem przepinać kable, żeby wszystko działało. Wkurzające niesłychanie. Na razie nie doszukałem się problemu z konkretnym kablem, gniazdem lub hubem. Zupełnie jakby komputer losował sobie co by tu teraz...

  • Haha 2
Link to post
Share on other sites

Próbowałeś bez zasialania huba? 
Na starym teleskopie mam huba 3.0 i też ma wtyczkę na zasilanie (jako ewentualność), ale z niej nie korzystam i mi działa na tym hubie: DF, Atik koło, Atik kamera, guider. Może jakieś skoki napięcia Ci coś psują... 

Link to post
Share on other sites

@kubaman mam to samo. Zasilam huba usb TP-Link UH700 na 12V z astrolinka. Raz łączy wszystko raz nie łączy tylko część. Muszę wpinać czasem kamerę osobno, choć ostatnio już tego nie robię i mam ją wpiętą w laptopa. Teraz rozłącza mi montaż.

Link to post
Share on other sites

Ten zasilacz, to jaką ma moc? Bo ja bym obstawiał, że po prostu nie wyrabia prądowo i nie jest w stanie zasilić porządnie wszystkiego. I pytanie, czy hub w ogóle jest w stanie podawać odpowiednio wysoki prąd, żeby kamera prawidłowo działała.

 

Dokładnie tak to wyglądało u mnie.

Jakiś czas temu wymyśliłem sobie, żeby podłączać się bezpośrednio do kompa stacjonarnego przez USB, żeby mieć materiał od razu tam, gdzie go będę obrabiał - przerzucanie danych z laptopa (nie ma złącza sieciowego, więc można tylko przez wifi) na stacjonarny przez wifi zajmuje strasznie dużo czasu, szczególnie jak mam nagrania planetarne/księżycowe (czasem setki gigabajtów). A tak cyk! i mogę nawet coś tam dłubać jak się kolejny plik nagrywa. W tym celu zainwestowałem w piętnastometrowy aktywny kabel USB 3.0 od Lindy - jak się rozstawiam na podwórku albo na balkonie, to se go puszczam przez okno (muszę coś sensowniejszego wymyślić, ale póki co działa spoko).

No i do sedna - sama kamera (ASI462) podłączona bezpośrednio do kompa tym kablem bez dodatkowego zasilania czasem działa, czasem nie, a jak działa, to wyciąga max 15 klatek na sekundę. Jak podłączę dodatkowe zasilanie, to jest OK i FPSy są takie, jakie fabryka dała. Jak popodłączałem wszystko (DreamFocuser - z własnym zasilaniem, montaż - również, kamera ASI462 zasilana z USB, druga kamera - Chameleon3 też z USB, ale on mało prądu bierze) do huba USB (TP-Link UH720), który był zasilany z dołączonego zasilacza (12V i bodaj 3,3A) - to ASI462 po prostu nie działa, albo na chwilę się pojawia i znika. A jak wziąłem mocniejszy zasilacz (13,8V, 10A), to kamera ładnie działa z pełną prędkością i nic się nie rozłącza.

  • Like 1
Link to post
Share on other sites

Używam TP-Link UH700

zasilam go z monta.

Wszystkie urządzenia rozpaznał bez zająknięcia. Wszystko działa bez jakichkolwiek zakłóceń, nigdy żadnego połączenia mi nie zerwało. Jeden kabelek do lapka i dziękuje :) zero problemów.

 

Edited by Maetrik
  • Like 3
Link to post
Share on other sites

Ja mam wiekowy komputerek Esprimo 5030 który ma 6 wyjść USB 2.0. Ja wiem, zaraz ktoś napisze - bo ma wewnętrzny hub- i to prawda. No tyle tylko że mam zero problemów

W wersji "dużego" setupu wisi montaż ASA, kamera, Koło, fokuser i odbiornik GPS.

W wersji "małego" setupu montaż Takahashi, kamera, fokuser, kamera guidera.

Od lat działa bez problemu. Ostatnio przy dużym setupie wymieniłem na komputerek X96 z WIN 10 i ponieważ jest odcięty od Internetu działa świetnie. Też bez huba, wystarcza 5 gniazd USB.

Edited by wessel
Link to post
Share on other sites
26 minut temu, Maetrik napisał:

Używam TP-Link UH700

zasilam go z monta.

Wszystkie urządzenia rozpaznał bez zająknięcia. Wszystko działa bez jakichkolwiek zakłóceń, nigdy żadnego połączenia mi nie zerwało. Jeden kabelek do lapka i dziękuje :) zero problemów.

 

Właśnie zamówiłem ten hub. W jaki sposób zasilasz go z monta?

Link to post
Share on other sites

Wg moich obserwacji, 90% problemów z USB to problem z niekontaktowaniem złącza. Wszystkie laptopy, z jakimi miałem do czynienia miały gówniane złącza - wtyczkę trzeba wpiąć w odpowiedni sposób, nie za mocno nie za słabo i potem broń boże nie dotykać :) Jedne kable lubią być wsadzone do końca, inne wręcz przeciwnie - trzeba je trochę cofnąć żeby kontaktowały.

Hubów używałem kilka i niektóre miały również gówniane, niekontaktujące gniazda, a inne dobre. Nie ma to nic wspólnego z ich ceną - można kupić drogi z syfem, albo tani idealny. Niestety nie mam nic do polecenia z USB3.

No i problemy zwykle pogłębiają się na mrozie.

 

Generalnie nie mogę zrozumieć, dlaczego producenci złącz mają taki problem ze spełnieniem standardu i dokumentacji usb. No chyba że projekt gniazda USB-A jest z założenia zły i te lepsze złącza wprowadziły swoje ulepszenia?

  • Like 1
Link to post
Share on other sites
Teraz, MateuszW napisał:

Wg moich obserwacji, 90% problemów z USB to problem z niekontaktowaniem złącza. Wszystkie laptopy, z jakimi miałem do czynienia miały gówniane złącza - wtyczkę trzeba wpiąć w odpowiedni sposób, nie za mocno nie za słabo i potem broń boże nie dotykać :) Jedne kable lubią być wsadzone do końca, inne wręcz przeciwnie - trzeba je trochę cofnąć żeby kontaktowały.

Hubów używałem kilka i niektóre miały również gówniane, niekontaktujące gniazda, a inne dobre. Nie ma to nic wspólnego z ich ceną - można kupić drogi z syfem, albo tani idealny. Niestety nie mam nic do polecenia z USB3.

No i problemy zwykle pogłębiają się na mrozie.

 

Generalnie nie mogę zrozumieć, dlaczego producenci złącz mają taki problem ze spełnieniem standardu i dokumentacji usb. No chyba że projekt gniazda USB-A jest z założenia zły i te lepsze złącza wprowadziły swoje ulepszenia?

 

Dziwne, że nie lepiej byłoby robić przez Ethernet? To dużo lepszy standard, dłuższe kable i wtyczki nigdy nie wypadają... :)

Link to post
Share on other sites
4 minuty temu, Behlur_Olderys napisał:

 

Dziwne, że nie lepiej byłoby robić przez Ethernet? To dużo lepszy standard, dłuższe kable i wtyczki nigdy nie wypadają... :)

Jest sporo problemów. 1 - to nie jest za bardzo zgodne z "filozofią" tych standardów - USB służy do łączenia urządzeń peryferyjnych, a ethernet komputerów (choć w przemyśle też urządzeń). 2 - ethernet jest trudniejszy w implementacji w małych urządzeniach, nie da się zrobić prostego konwertera na uart i śmigać na atmedze8 :) Złącze ethernet jest duże - w części urządzeń nawet by się nie zmieściło. Switch ethernet jest również dużo większy i droższy od huba usb. Jest problem z zasilaniem - co prawda jest POE ale w wielu niezgodnych wariantach, a switch z poe kosztuje majątek. No i trzeba jakoś "ogarnąć" tą sieć, mieć serwer dhcp, znać adresy urządzeń itd. W konfiguracji byłoby to skomplikowane. No i jeszcze jedno - do użytku z kamerami ethernet 1Gb jest z kolei za wolny, a wszystkie szybsze nie są zbyt standardowe, a tym bardziej w laptopach więcej nie montują.

Ogólnie to dałoby się i pewnie działoby lepiej, ale nasze setupy musiałyby ważyć tak 2x więcej i tyleż więcej kosztować :) No może trochę pesymistycznie.

Ale największy problem to brak przyjętej "tradycji" - żeby to miało sens, to każde urządzenie musiałoby mieć ethernet, a jeśli inne nie mają, to tego jednego też nikt tak nie podłączy bo to będzie niewygodne. Choćby właśnie montaże iOptrona mają opcjonalnie ethernet, no ale co z tego jak 10 innych urządzeń które używasz już potrzebuje USB. Dla prostoty lepiej podpiąć wtedy wszystko w jeden sposób.

 

A żeby nie było - kamera nagrywająca otwarcie spadochronu na Perseverance używa USB3 :P I jest to pierwsze wykorzystanie tego protokołu na Marsie.

  • Like 1
Link to post
Share on other sites
3 minuty temu, MateuszW napisał:

kamera nagrywająca otwarcie spadochronu na Perseverance używa USB3

Swoją drogą - te kamery "inżynieryjne" to po prostu Chameleony 3 (w wersji kolorowej) od FLIRa.

 

Godzinę temu, apolkowski napisał:

A USB->RJ45 nie pomoże?

Pomóc by pewnie pomogło, ale USB3 raczej i tak jest szybsze, no i w ten sposób od razu mam dane tam, gdzie mają być. I mogę sobie wygodnie sterować całą zabawą z mojego "centrum dowodzenia", zamiast siedzieć na dworze w zimnie :D

Poza tym ten mój laptopek to jest taki mały i dość gówniany, jego główną zaletą jest to, że jest mały :) I przede wszystkim ma mało RAMu, więc dość szybko maksymalne FPSy są ograniczone przez prędkość zapisu na dysku; na stacjonarnym mam sporo więcej RAMu i szybszy dysk.

Link to post
Share on other sites
8 minut temu, MateuszW napisał:

Dla prostoty lepiej podpiąć wtedy wszystko w jeden sposób.

Czyli - innymi słowy - ch**owo, ale jednakowo :)

 

Robię ostatnio w branży automotive i tam wszystko jest na Ethernecie, ze względu na niezawodność i szybkość przesyłu. Nawet sygnały z kamer/radarów/lidarów - co tam chcesz. Danych jest mnóstwo.

 

Ciekawe, czy by dało radę jakoś to załatwić. ASCOM też przechodzi powoli z COM-a w domenę REST :)

 

Link to post
Share on other sites

Ja długo walczyłem, by puścić wszystko z domu po sieci (tj. komp mieć w domu, a telep na tarasie). Przerabiałem nawet egzotyczne rozwiązania typu serwery USB (urządzenie, która ma wyjścia USB, ale do którego łączysz się Ethernetem). Kupowałem też drogie i tanie przedłużacze i huby. Ja piszecie: czasami działało, zwykle nie. Stanęło więc na mini-kompie sterującym przy telepie, z którym łączę się po WiFi (VNC). Do podglądu w trybie rzeczywistym wystarcza, do przesyłu pojedynczych zdjęć (4MB) też, ale większe operacje to po zgraniu na główny komp rano.
Najwęższym gardłem i najbardziej wrażliwym elementem jest połączenie kamera-komputer. Tu lecą konkretne dane. A jak nie lecą, bo kamera się blokuje, to tracisz to co najcenniejsze - czas i fotony. Reszta obciążeń to jakieś pyłki.

Pzdr,
Gajowy

Link to post
Share on other sites
8 minut temu, Behlur_Olderys napisał:

ch**owo, ale jednakowo

Jak w naszym wojsku :D

Ale w sumie jest sporo kamer przemysłowych/naukowych na Ethernecie, tylko wersje na "zwykłym" gigabitowym ethernecie są niestety wolniejsze od USB 3, a te hulające na 10G kosztują majątek. Jest jeszcze coś takiego jak Camera Link, ale w najszybszej wersji maksymalna teoretyczna prędkość to 850MB/s, więc duużo mniej niż USB.

Edited by Krzysztof z Bagien
Link to post
Share on other sites
52 minuty temu, Krzysztof z Bagien napisał:

Swoją drogą - te kamery "inżynieryjne" to po prostu Chameleony 3 (w wersji kolorowej) od FLIRa.

Moja kamera na Marsie :brawo:

51 minut temu, Behlur_Olderys napisał:

Robię ostatnio w branży automotive i tam wszystko jest na Ethernecie

Ale to chyba nie jest taki standardowy ethernet (w sensie stos protokołów), jak w zwykłych zastosowaniach, tylko któraś z tych przemysłowych odmian, prawda? Pytanie czy robi to różnicę w kontekście naszych zastosowań (systemu czasu rzeczywistego tu nie mamy).

43 minuty temu, Krzysztof z Bagien napisał:

Ale w sumie jest sporo kamer przemysłowych/naukowych na Ethernecie, tylko wersje na "zwykłym" gigabitowym ethernecie są niestety wolniejsze od USB 3, a te hulające na 10G kosztują majątek.

No właśnie. A potrzebujesz jeszcze mieć komputer z tym 10GBit. Raczej to już musi być standardowy PC z kartą rozszerzeń pci-express. Albo jakaś egzotyczna (i droga) konstrukcja z wbudowanym portem. Albo... adapter ethernet - > USB3 :P :P 

Edited by MateuszW
  • Haha 1
Link to post
Share on other sites
47 minut temu, Behlur_Olderys napisał:

 

To są standardy telewizji przemysłowej (ktoś mnie poprawi jeśli się mylę...) I to są formaty stratne. Jakieś PAL-e itp...

To jest standard fizycznego połączenia, używanego do kamer przemysłowych i naukowych. Na dobrą sprawę można tym chyba przesłać cokolwiek, tak samo jak przez Ethernet czy USB, bo to przecież dane cyfrowe. Jak ktoś ma fantazję, to pewnie może se te dane kompresować.

Link to post
Share on other sites

Kuba ja z tym walczyłem blisko rok w swojej zdalnej budce, też miałem takie cyrki.

U mnie problemem była pętla masy.

I nie duże okresowo pojawiające się zwarcie w przedłużaczu.

Dodatkowo pamiętaj by zasilać urządzenia we właściwy sposób (np jeśli masz instalacje elektryczną w danym miejscu bez uziemienia to stosuj też przedłużacze i wtyczki bez uziemienia na dwa przewody, analogicznie jeśli masz uziemienie to odwrotnie, stosuj 3 żyłowe okablowanie) Nie jest to jakoś mega ważne ale mnie znajomy elektryk przekonał że warto się do tego stosować, zwłaszcza jeśli nie znamy budowy chińskiego przedłużacza jak jest wykonany w środku.

Po przerwaniu jej uzyskałem lepszą stabilność połączeń USB.

Zbadaj czy u siebie nie masz podobnego problemu, masz masę sprzętu więc i wysokie prawdopodobieństwo że u ciebie to zjawisko występuje.

Może coś ci to rozjaśni sytuacje, zbadaj temat.

Nie pytaj mnie dokładnie o szczegóły bo się na tym aż tak nie znam, ale przekonałem się że zasilanie sprzętu prawidłowo od podstaw jest szalenie ważne.

Edited by Imar
  • Like 4
Link to post
Share on other sites
Godzinę temu, MateuszW napisał:

Ale to chyba nie jest taki standardowy ethernet

 

Ethernet, no, zwykły w sensie dwóch czy trzech pierwszych warstw: 

Na dole 1000Base-T czyli 1Gb/s. (USB3.0 ma teoretycznie 5Gb/s). Oczywiście, wydaje mi się, że na potrzeby astrofoto wystarczyłoby pewnie 100Base-T, gdyby wyciągnąć z niego maxa. 

Link layer to IP, a protokół na warstwie network to - bez zaskoczenia - TCP/UDP.

 

33 minuty temu, Krzysztof z Bagien napisał:

To jest standard fizycznego połączenia, używanego do kamer przemysłowych i naukowych. Na dobrą sprawę można tym chyba przesłać cokolwiek, tak samo jak przez Ethernet czy USB, bo to przecież dane cyfrowe.

Ja wiem, dokonałem skrótu myślowego :) Chodzi mi o to, że te kamery mają soft - w sensie formatu przesyłu - stratny, bo mają po prostu przesyłać obraz telewizyjny. Rzadko kiedy widziałem połączenie kamery z CameraLinkiem  czy GigE z formatem RAW RGB czy też RAW mono. W drugą stronę - nie widziałem jeszcze kamery astro z Ethernetem, a nie USB.

Link to post
Share on other sites
2 godziny temu, Behlur_Olderys napisał:

Oczywiście, wydaje mi się, że na potrzeby astrofoto wystarczyłoby pewnie 100Base-T, gdyby wyciągnąć z niego maxa. 

Do foto DS, kamerą o "normalnej" ilości pikseli pewnie tak. Ale już nowsze CMOS nawet przy DS potrafią potrzebować transferu, a przy planetach nawet nie ma o czym mówić. 

2 godziny temu, Behlur_Olderys napisał:

W drugą stronę - nie widziałem jeszcze kamery astro z Ethernetem, a nie USB.

A światłowód może być? :) https://www.qhyccd.com/index.php?m=content&c=index&a=show&catid=94&id=55&cut=1

2*10 Gigabit Fiber Port

Do tego dedykowana karta za 4 koła, ale to już grosze :) 

 

Swoją drogą, ciekawe kiedy będzie w astro upgrade USB z tzw 3.0 na USB 3.2 Gen 2 lub USB 3.2 Gen 2x2 (ale dziwak wymyślił te nazwy :) )

  • Like 1
Link to post
Share on other sites

Pozwólcie, że przy okazji tematu o habach zadam pytanie:

mam w budce taki jak na zdjęciu D-Link DUB-H7. Przewody mam wpięte tylko w pięć gniazd po lewej stronie. Do czego służą te dwa gniazda po prawej oznaczone symbolem jakby baterii? W necie znalazłem dwa rodzaje tych hubów: jedne mają ten opis jak na zdjęciu, a inne nie mają... ale opisy dla wszystkich mówią o siedmiu gniazdach USB, nie wyjaśniają przeznaczenia tych dwóch gniazd. 

Może ktoś zna odpowiedź?

image.png.f3359bd0c53832f9affa74d1f56a3bb6.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Our picks

    • Big Bang remnant - Ursa Major Arc or UMa Arc
      Tytuł nieco przekorny bo nie chodzi tu oczywiście o Wielki Wybuch ale ... zacznijmy od początku.
       
      W roku 1997 Peter McCullough używając eksperymentalnej kamery nagrał w paśmie Ha długą na 2 stopnie prostą linie przecinajacą niebo.
       
      Peter McCullough na konferencji pokazał fotografię Robertowi Benjamin i obaj byli pod wrażeniem - padło nawet stwierdzenie: “In astronomy, you never see perfectly straight lines in the sky,”
        • Love
        • Thanks
        • Like
      • 14 replies
    • Jeśli coś jest głupie, ale działa, to nie jest głupie - o nietypowych rozwiązaniach sprzętowych
      Sformułowanie, które można znaleźć w internetach jako jedno z "praw Murphy'ego" przyszło mi na myśl, gdy kolejny raz przeglądałem zdjęcia na telefonie z ostatniego zlotu, mając z tyłu głowy najgłośniejszy marsjański temat na forum. Do rzeczy - jakie macie (bardzo) nietypowe patenty na usprawnienie sprzętu astronomicznego bądź jakieś kreatywne improwizacje w razie awarii czy niezabrania jakiegoś elementu sprzętu  Obstawiam, że @HAMAL mógłby samodzielnie wypełnić treścią taki wątek.
        • Haha
        • Like
      • 21 replies
    • MARS 2020 - mapa albedo powierzchni + pełny obrót 3D  (tutorial gratis)
      Dzisiejszej nocy mamy opozycję Marsa więc to chyba dobry moment żeby zaprezentować wyniki mojego wrześniowego projektu. Pogody ostatnio jak na lekarstwo – od początku października praktycznie nie udało mi się fotografować. Na szczęście wrzesień dopisał jeśli chodzi o warunki seeingowe i udało mi się skończyć długo planowany projekt pełnej mapy powierzchni (struktur albedo) Marsa.
        • Love
        • Thanks
        • Like
      • 130 replies
    • Aktualizacja silnika Astropolis - zgłaszanie uwag
      Dzisiaj zaktualizowaliśmy silnik Astropolis do najnowszej wersji (głównie z powodów bezpieczeństwa). Najpoważniejsze błędy zostały już naprawione, ale ponieważ aktualizacja jest dosyć rozbudowana (dotyczy także wyglądu), drobnych problemów na pewno jest więcej. Bez was ich nie namierzymy. Dlatego bardzo proszę o pomoc i wrzucanie tu informacji o napotkanych problemach/błędach.
        • Like
      • 250 replies
    • Insight Investment Astrophotographer of the Year 2020 – mój mały-wielki sukces :)
      Jestem raczej osobą która nie lubi się chwalić i przechwalać… ale tym razem jest to wydarzenie dla mnie tak ważne, że postanowiłem podzielić się z Wami tą niezwykle radosną dla mnie wiadomością.
       
      Moja praca zajęła pierwsze miejsce w kategorii „Planety, komety i asteroidy” podczas tegorocznego konkursu Insight Investment Astronomy Photographer of the Year 2020.
        • Love
        • Thanks
        • Like
      • 85 replies
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.