Jump to content

ASCOM Alpaca


Imar
 Share

Recommended Posts

Witam, muszę się podpytać bo mam problemy z połączeniem się po przez alpake.

Wykonałem wszystkie kroki opisane tutaj przez Jolo identycznie, nawet mam ten sam sprzęt i te same sterowniki to były.

https://www.forumastronomiczne.pl/index.php?/topic/19146-ascom-alpaca-nie-tylko-lokalnie-i-nie-tylko-windows/

Komputer z uruchomionym remote server zainicjował poprawnie sterowniki to jest Eqmoda i Astrolinka focuser. Potwierdza to też konsola.

O dokładnie tak.

alpaca-02.jpg.e92083a9ad502249223a9da679

Przy próbie połączenia na innym pc  w jakim kolwiek sofcie dostaje komunikat po ang że czas oczekiwania minął i połączenie nie następuje.

Oczywiście mam zainstalowany Ascom remote client na drugim PC i samą platforme ASCOM.

Oczywiście wybieram w sterowniku Ascom remote driver i wpisuje poprawnie port i ip komputera na którym jest serwer, dla pewności wyłączyłem antywirusy, powyłączałem zapory.

Czy jest jakiś sposób bym się zorientował czy miedzy dwoma komputerami w ogóle stworzyło się połączenie na tym porcie  (domyślny 11111) ? bo może konsola podaje że serwer ruszył ale nie ma zadnego połączenia w sieci lokalnej.

 

Nie wiem jak to opisać lepiej, całość powinna być dziecinnie prosta, z opisu na git hub ( tam gdzie pobieramy remote server) wynika że wszystko zainstalowałem co potrzebuje w taki wersjach jakie powinny być.

Powinno łączyć ale nie chce..

Edited by Selmak
Link to comment
Share on other sites

W PDF jest napisane że można sprawdzić połączenie w ten sposób "For testing its fine to run the driver and the remote server on the same PC and to use 127.0.0.1 as the IP address for both clients and server"

Zrobiłem to i dostaje komunikat że nie można się połączyć z serwerem zdalnym ( mimo że to ten sam PC) jak to rozumieć ?

Link to comment
Share on other sites

1 godzinę temu, Selmak napisał:

Przy próbie połączenia na innym pc  w jakim kolwiek sofcie dostaje komunikat po ang że czas oczekiwania minął i połączenie nie następuje.

Jest wysoce prawdopodobne, że port 11111 wycinasz na firewallu twojego Windowsa. Winda domyślnie wycina połączenia przychodzące.

Dodaj wyjątek dla portu 11111w regułach firewalla na maszynie, na której działa serwer.

Do przetestowania czy port jest osiągalny z drugiej maszyny można wykorzystać program zdalnego terminala, np. putty łącząc się nim na tenże port.

Link to comment
Share on other sites

Mam to u siebie działające, ale będę w domu dopiero w poniedziałek. Jeśli nie rozwiążesz problemu do tego czasu, to może coś pomogę. Pamiętam, że miałem problem z tymi "remote drivers", bo one wymagały dodania w platformie. Nie wystarczyło uruchomienie samej platformy na kliencie. Trzeba było w niej pododawać te sterowniki.

EDIT. Odpaliłem laptopa z serwerem i klienta na stacjonarnym.

Jeśli masz platformę 6.5 to korzystasz z Device Hub. W Device Hub wybierasz np. teleskop, potem wybierasz z menu Alpaca/Create Alpaca Driver, nadajesz mu nazwę, wybierasz ten nowo nazwany driver z listy, wybierasz properties i tam wpisujesz adres serwera. Tak trzeba zrobić ze wszystkimi sterownikami.

image.png.796fbb3a0b5e6d672be8f691802e6efc.png

Edited by apolkowski
Link to comment
Share on other sites

11 godzin temu, apolkowski napisał:

Mam to u siebie działające, ale będę w domu dopiero w poniedziałek. Jeśli nie rozwiążesz problemu do tego czasu, to może coś pomogę. Pamiętam, że miałem problem z tymi "remote drivers", bo one wymagały dodania w platformie. Nie wystarczyło uruchomienie samej platformy na kliencie. Trzeba było w niej pododawać te sterowniki.

EDIT. Odpaliłem laptopa z serwerem i klienta na stacjonarnym.

Jeśli masz platformę 6.5 to korzystasz z Device Hub. W Device Hub wybierasz np. teleskop, potem wybierasz z menu Alpaca/Create Alpaca Driver, nadajesz mu nazwę, wybierasz ten nowo nazwany driver z listy, wybierasz properties i tam wpisujesz adres serwera. Tak trzeba zrobić ze wszystkimi sterownikami.

image.png.796fbb3a0b5e6d672be8f691802e6efc.png

Udało mi się połączyć ale wszystko działa tak wolno że szok, maxim się zawiesza jak łączę się z kamerą, na kompie gdzie serwer w konsoli sygnał że się połączyło a maxim zawieszony.

Jedyny port na jakim nawiązałem łączność to 65535 na innych nie chce.

Klatkę z asi 120 która zajmuje 2 mb pobiera ze 3 minuty.

Edited by Selmak
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Our picks

    • Migracja Astropolis na nowy serwer - opinie
      Kilka dni temu mogliście przeczytać komunikat o wyłączeniu forum na dobę, co miało związek z migracją na nowy serwer. Tym razem nie przenosiłem Astropolis na większy i szybszy serwer - celem była redukcja dosyć wysokich kosztów (ok 17 tys rocznie za dedykowany serwer z administracją). Biorąc pod uwagę fakt, że płacę z własnej kieszeni, a forum jest organizacją w 100% non profit (nie przynosi żadnego dochodu), nie znalazłem w sobie uzasadnienia na dalsze akceptowanie tych kosztów.
        • Thanks
        • Like
      • 60 replies
    • Droga Mleczna w dwóch gigapikselach
      Zdjęcie jest mozaiką 110 kadrów, każdy po 4 minuty ekspozycji na ISO 400. Wykorzystałem dwa teleskopy Takahashi Epsilon 130D i dwa aparaty Nikon D810A zamocowane na montażu Losmandy G11 wynajętym na miejscu. Teleskopy były ustawione względem siebie pod lekkim kątem, aby umożliwić fotografowanie dwóch fragmentów mozaiki za jednym razem.
        • Love
        • Thanks
        • Like
      • 48 replies
    • Przelot ISS z ogniskowej 2350 mm
      Cześć, po kilku podejściach w końcu udało mi się odpowiednio przygotować cały sprzęt i nadążyć za ISS bez stracenia jej ani razu z pola widzenia. Wykorzystałem do tego montaż Rainbow RST-135, który posiada sprzętową możliwość śledzenia satelitów.
      Celestron Edge 9,25" + ZWO ASI183MM. Czas ekspozycji 6 ms na klatkę, końcowy film składa się z grup 40 klatek stackowanych, wyostrzanych i powiększonych 250%.
      W przyszłości chciałbym wrócić do tematu z kamerką ASI174MM, która z barlowem 2x da mi podobną skalę, ale 5-6 razy większą liczbę klatek na sekundę.
      Poniżej film z przelotu, na dole najlepsza klatka.
        • Love
        • Thanks
        • Like
      • 73 replies
    • Big Bang remnant - Ursa Major Arc or UMa Arc
      Tytuł nieco przekorny bo nie chodzi tu oczywiście o Wielki Wybuch ale ... zacznijmy od początku.
       
      W roku 1997 Peter McCullough używając eksperymentalnej kamery nagrał w paśmie Ha długą na 2 stopnie prostą linie przecinajacą niebo.
       
      Peter McCullough na konferencji pokazał fotografię Robertowi Benjamin i obaj byli pod wrażeniem - padło nawet stwierdzenie: “In astronomy, you never see perfectly straight lines in the sky,”
        • Love
        • Thanks
        • Like
      • 17 replies
    • Jeśli coś jest głupie, ale działa, to nie jest głupie - o nietypowych rozwiązaniach sprzętowych
      Sformułowanie, które można znaleźć w internetach jako jedno z "praw Murphy'ego" przyszło mi na myśl, gdy kolejny raz przeglądałem zdjęcia na telefonie z ostatniego zlotu, mając z tyłu głowy najgłośniejszy marsjański temat na forum. Do rzeczy - jakie macie (bardzo) nietypowe patenty na usprawnienie sprzętu astronomicznego bądź jakieś kreatywne improwizacje w razie awarii czy niezabrania jakiegoś elementu sprzętu  Obstawiam, że @HAMAL mógłby samodzielnie wypełnić treścią taki wątek.
        • Haha
        • Like
      • 43 replies
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.