Skocz do zawartości
RadekK

Astroberry Server

Rekomendowane odpowiedzi

Mój chyba też pisze że nie ma internetu, bo Astroberry nie łączy z internetem.

Tam gdzie masz wpisane VNC server: astroberry.local::5900, ja u siebę wpisuję 192.168.10.1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

 Sprawdzę  192.168.10.1:5900 ?

Edytowane przez Selmak

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
1 hour ago, Selmak said:

Edytowałem plik hostapd.conf jak kolega ze zmianą na G oraz kanałem na 6 i owszem wifi dostępne i widoczne jednak po podłączeniu do sieci wyskakuje..brak internetu i vnc nie łączy się..jakieś pomysły?

Kochani, mamy tu chyba jakieś nieporozumienie. System działa tak, że ALBO aktywny jest wirtualny access point ALBO system jest podłączony do innego access pointa (w tym podłączonego do internetu). Jeśli aktywny jest wirtualny access point (astroberry) to system NIE JEST podłączony do innego routera/access pointa, a to znaczy że nie ma połączenia z internetem. Jeśli chcecie w sieci mieć dostęp do astroberry I JEDNOCZEŚNIE mieć połaczenie z internetem to MUSICIE po pierwszym uruchomieniu skonfigurowac połączenie z routerem/access pointem, który jest podłączony do internetu. Po podłączeniu wirtualny access point (sieć wifi astroberry) jest automatycznie wyłączany i cały system jest dostępny w waszej sieci wewnętrznej pod adresem, który przyznaje router/access point. To znaczy że normalnie łączycie się do swojej sieci domowej i w niej dostępny jest Astroberry Server z adresem skonfigurowanym dla sieci domowej. Jeśli pojedziecie w teren i router/access point domowy nie jest dostępny to automatycznie włącza się wirtualny access point (sieć wifi astroberry), ale BEZ połączenia z internetem (bo skąd) a Astroberry Server dostępny jest pod adresem 192.168.10.1. W każdej sytuacji wystarczy użyć astroberry.local zamiast adresu IP żeby połączyć się z Astroberry Server.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
4 godziny temu, Adm2 napisał:

Mój chyba też pisze że nie ma internetu, bo Astroberry nie łączy z internetem.

Tam gdzie masz wpisane VNC server: astroberry.local::5900, ja u siebę wpisuję 192.168.10.1

No więc skoro tak..to czy podając IP czy astroberry.local powinno mnie łączyć.. A niestety nie. Pokombinuje z tym.

Edit: 192.168.10.1:5900 łączy bez problemu, dziękuje panowie.

Tymczasem udało się połączyć kablem ethernet do internetu i za pomocą software boutique zainstalowac przeglądarkę chromium, działa jak trzeba.

Pozostaje tylko kwestia zegara który się resetuje co uruchomienie rpi z datą około 2 lat wstecz..upierdliwe to..jak mogę na stałe zmienić czas i datę?

Edytowane przez Selmak
  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
9 hours ago, RadekK said:

I mówisz o kstars-bleeding? Dopytuję bo nie mam nigdzie gotowego raspbiana, żeby sprawdzić.

bleeding to pewnie nie, ale chyba najnowsza stabilna

Package: kstars
Source: kstars (5:2.9.8-1)
Version: 5:2.9.8-1+b3
Architecture: armhf

Package: indi-bin
Source: libindi
Version: 1.7.5+dfsg-1

Package: astrometry.net
Source: astrometry.net (0.76+dfsg-1)
Version: 0.76+dfsg-1+b6
Architecture: armhf

Spis i wersje wszystkich pakietów z testing/main możesz zobaczyć tutaj.

 

W kwestii instalacji:

- pobrałem oficjalny obraz Raspbiana stable,

- uruchomiłem,

- w /etc/apt/sources.list zmieniłem na testing

- apt-get update && apt-get dist-upgrade

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
7 hours ago, Selmak said:

Pozostaje tylko kwestia zegara który się resetuje co uruchomienie rpi z datą około 2 lat wstecz..upierdliwe to..jak mogę na stałe zmienić czas i datę?

Malina nie ma zegara RTC, rozwiązań jest kilka:

- dokupić zegar (najlepiej z GPS),

- jak masz podłączony Pi do internetu to ntp powinno pobrać date i czas,

- ustawiać ręcznie po każdym włączeniu.

 

7 hours ago, RadekK said:

System działa tak, że ALBO aktywny jest wirtualny access point ALBO system jest podłączony do innego access pointa

Jako ciekawostkę napiszę, że moduł wifi z wersji 3B+ obsługuje tryb dualny - tzn jest i AP i klientem w tym samym czasie (oczywiście na tym samym kanale bo jest jedno radio). Tak to działa u mnie i wydaje się stabilne. Tylko kwestia konfiguracji, która zabrała mi 2 wieczory przez prostą rzecz (hostapd musi wstać wcześniej niż wpa-supplicant). 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
9 hours ago, Sebo_b said:

moduł wifi z wersji 3B+ obsługuje tryb dualny - tzn jest i AP i klientem w tym samym czasie

Zgadza się. Tryb dualny dział również we wszystkich poprzednich wersjach Astroberry. Na 3B+ jest problem ze względu na to, że moduł jest dwupasmowy (2.4/5G) i dla konkretnej konfiguracji można to bez problemu skonfigurować (tak jak Ty zrobiłeś u siebie) ale zrobienie tego dla dowolnego użytkownika z dowolnym sprzętem (nie skalując wszystkich do trybu G/N) to już problem. Mam tu na mysli kombinatorykę wersji sprzętu który może mieć użytkownik:

- PC z AC / router z AC

- PC bez AC / router z AC

- PC z AC / router bez AC

- PC bez AC / router bez AC

(temat na odrębną teczniczną dyskusję)

 

Obecnie działa tak:

- po uruchomieniu systemu na 3B+ odpala się domyślnie VAP w trybie AC 5GHz, a na 3B odpala się VAP w trybie G/N na 2.4GHz --> łączymy się do sieci wifi "astroberry", brak internetu

- po skonfigurowaniu połączenia do innego access pointa VAP się wyłącza (własnie ze względu na wymaganie że obie sieci muszą działać na tym samym kanale) --> łączymy się do swojej sieci wifi i system dostępny jest w niej pod adresem astroberry.local albo IP z naszej sieci, jest dostęp do internetu

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jedno pytanie dotyczące 3B+ z którym właśnie walczę z instalacją systemu.

Jeśli mój router nie ma trybu 5GHz to czy wystarczy podpiąć malinę kablem LAN do routera domowego, żeby złapać kontakt wzrokowy poprzez VNC i dopiero zmienić ustawienia WiFi?

Zaznaczam, że nie mam dostępu do monitora z HDMI, więc muszę walczyć w ten sposób, no chyba że można coś zmienić w którymś z plików systemowych na karcie, żeby z automatu ruszało 2,4GHz?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Wystarczy podpiąć kablem i ustawić wszystko. Astroberry server powinien być dostępny pod adresem astroberry.local a jeśli nie to możesz sprawdzić w ustawieniach routera jaki dostał adres IP. Ewentualnie możesz użyć czegoś w stylu fing na androida. Wpisujesz adres w przeglądarce i już ;)

 

 

  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dzięki, właśnie tak zrobiłem jak napisałeś i potwierdzam, że działa :)

Teraz ustawiam wszystko po kolei w sieci WLAN i zaczynam podpinanie kamerki.

Pozdrawiam :Beer:

  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

No więc kilka moich doświadczeń z instalowania Astroberry na Raspberry Pi 3 B+ :)

Najpierw dałem ciała i próbowałem użyć nierozpakowanego obrazu systemu, co skończyło się oczywiście klapą, więc informuję że mimo że Etcher  ma w opisie pliki "xz" to mi wyskakiwał ciągle błąd, a po rozpakowaniu obrazu poszło pięknie i bez problemów (działałem na WIN 10).

Żeby nie męczyć się z pierwszym połączeniem, to jak napisał Radek - kabel LAN i święty spokój. Tablet z WIN 8 bez problemu połączył się, poprzez adres astroberry.local

Pierwsze wrażenia bardzo pozytywne, ale już mogę zapewnić że z ekranem 3,2" lepiej nie zaczynać :D

Jedyny problem to odprowadzanie ciepła. Ja mam wklejone dwa radiatory aluminiowe, ale trzeci, który chyba miał iść na kość pamięci od spodu nie mieści się w mojej zgrabnej obudowie.

Teraz muszę tylko się zastanowić czy nie dodać jakiegoś wentylatorka, bo po 30 minutach prób z kamerką ASI 120mm obudowa miała skromne 54 stopnie Celsjusza, ale co tam skoro na trójce bez plusa wyszła komuś na procku prawie setka :D

Gdyby ktoś chciał się podzielić swoimi doświadczeniami z chłodzeniem maliny, to proszę pisać, tylko nie wiem czy tutaj, czy zakładamy osobny temat?

Generalnie to Pi 3 B+ widzi ASI 120mm, ale jeszcze nie doszedłem, którym programem najlepiej ją obsługiwać do DS-ów. Do planet pewnie będzie za wolno, bo doszedłem do 9 fps.

Póki co tylko jeden program pokazał mi jakikolwiek obraz (dobry znak), ale jeszcze nie udało mi się ustawić próbnej sesji np 100x po 5sekund.

Jutro dalsza zabawa, ale widzę że potencjał jest :)

Jeszcze jedno pytanie, czy Pi 3 B+ pociągnie na zasilaczu tylko 2,1A? Teraz używam oryginalnego z logiem maliny na 2,5A (sieciowy), a potrzebuję być mobilny i najmocniejszy zasilacz 12/5V mam 2,1A :)

Pozdro :Beer:

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
46 minutes ago, Piotrek L. said:

ale jeszcze nie doszedłem, którym programem najlepiej ją obsługiwać

Jak to? Kstars z odpalonym Ekos. 

 

46 minutes ago, Piotrek L. said:

Jeszcze jedno pytanie, czy Pi 3 B+ pociągnie na zasilaczu tylko 2,1A?

2.5A ma na pewno zapas mocy wliczony. Poza tym max z usb to 1.2A, więc na samą malinę zostaje max 1.3A. Jeśli podłączasz tylko 120mc-s to ta kamera pobiera max 150mA, więc nie powinieneś potrzebować więcej niż 1.45A łącznie. 

  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Kiedyś mierzyłem pobór prądu mojej Raspbery pi 3 B, bez żadnego monitorka, wszystko przez wifi.

Zaraz po włączeniu jej, ciągnie 250-300mA.

Jak już jest włączona 160mA

Z włączonym INDI, podczas GoTo, kiedy krokowce się obracały   200 - 260mA.

Podpięty Canonn 600D nic nie zmienił w poborze prądu.

Więc max 300mA jak pobór był największy.

 

 

 

 

  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
1 hour ago, Piotrek L. said:

Pierwsze wrażenia bardzo pozytywne, ale już mogę zapewnić że z ekranem 3,2" lepiej nie zaczynać :D

Ekran 3,2" to zdecydowanie za mało na taki system ALE cały ekran możesz przeskalować ustawiając w bocznym menu (tym wysuwanym z lewej w przeglądarce) local scaling. Wtedy wszystko będzie pomniejszone i zmieści się nawet na malutkim ekraniku.

 

1 hour ago, Piotrek L. said:

Generalnie to Pi 3 B+ widzi ASI 120mm, ale jeszcze nie doszedłem, którym programem najlepiej ją obsługiwać do DS-ów. Do planet pewnie będzie za wolno, bo doszedłem do 9 fps.

Wszystko co potrebujesz do DS-ów to Ekos. Do planet doskonale sprawdza się oaCapture. Obsługa kamer ZWO w wersji USB 2.0 jest... wolna, ale jeśli zrobisz crop, zamiast pełnej rozdzielczości, której w takiej sytuacji nie potrzebujesz, to osiągniesz nawet 100 fps. Sam używam tej kamery do obiektów US i sprawdza się całkiem przyzwoicie. Kiedy nie uzywam jej do obiektów US to guiduję nią w PHD2 - działa doskonale.

 

1 hour ago, Piotrek L. said:

Jedyny problem to odprowadzanie ciepła. Ja mam wklejone dwa radiatory aluminiowe, ale trzeci, który chyba miał iść na kość pamięci od spodu nie mieści się w mojej zgrabnej obudowie.

Tego problemu nie zauważyłem u siebie, a używam dwóch radiatorów. Może obudowa zbyt szczelna/hermetyczna i nie masz wymiany ciepła z otoczeniem?

 

1 hour ago, Piotrek L. said:

czy Pi 3 B+ pociągnie na zasilaczu tylko 2,1A

Da radę, ale moim zdaniem to niewielki zapas wobec wymagań. Co prawda jak napisał @Adm2 pobór w normalnych warunkach nie jest duży, ale w zależności od tego co podłączysz do USB będzie brało więcej. Z moich testów wynika, że RPi startowo pobiera do 750mA.

  • Lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
W dniu 15.12.2018 o 11:00, RadekK napisał:

Obecnie działa tak:

- po uruchomieniu systemu na 3B+ odpala się domyślnie VAP w trybie AC 5GHz, a na 3B odpala się VAP w trybie G/N na 2.4GHz --> łączymy się do sieci wifi "astroberry", brak internetu

U mnie na malince 3B nie wykrywa tego automatycznie i trzeba wyedytować ręcznie plik hostepad.

 

W dniu 15.12.2018 o 11:00, RadekK napisał:

- po skonfigurowaniu połączenia do innego access pointa VAP się wyłącza (własnie ze względu na wymaganie że obie sieci muszą działać na tym samym kanale) --> łączymy się do swojej sieci wifi i system dostępny jest w niej pod adresem astroberry.local albo IP z naszej sieci, jest dostęp do internetu

Czyli po ustawieniu połączenia do swojej sieci wifi vap jest wyłączany na stałe i system nie sprawdza już tego przy uruchomieniu?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
15 minutes ago, wylam said:

Czyli po ustawieniu połączenia do swojej sieci wifi vap jest wyłączany na stałe i system nie sprawdza już tego przy uruchomieniu?

Nie na stałe. System sprawdza dostępność sieci w tle co jakiś czas w trakcie działania. Jeśli sieć będzie niedostępna to automatycznie uruchomi VAP. Dzięki temu nawet w przypadku utraty połączenia mamy możliwość podłączenia do VAP.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Witam ponownie...moja malina ma znów swoje humory...poprzednio skorzystałem z edycji pliku hostapd.conf gdzie zmieniłem tryb sieci na g czyli 2.4gh oraz do pliku hostapd.conf w folderze default podstawiłem rubrykę 

DAEMON_CONF="/etc/hostapd/hostapd.conf"

Wszystko według instrukcji z tej strony.

https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md

I hot spot startował po 5-10 minutach, łaczyłem się i mogłem sterować przez vnc.

Dziś uruchamiam malinę chyba 10 raz i czekam i czekam i nie ma sieci. Niczego nie zmieniałem w ustawieniach i są one takie same, zmieniło się tylko to że brak punktu dostępu widocznego...co mogę zrobić? Ręce opadają normalnie. Heh

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
1 hour ago, Selmak said:

DAEMON_CONF="/etc/hostapd/hostapd.conf"

W ten sposób zmieniłeś konfigurację systemu na własną. W efekcie w tle konkurują skrypty z Astroberry Server z Twoimi zmianami (hostapd działający jako usługa i konkurujący z automatem odpalającym go tak jak opisałem wyżej). Jeśli chcesz sam skonfigurować swój system to zacznij od wyłączenia automatu w pliku /etc/rc.local dodając # przed linią check-wlanconn > /dev/null 2>&1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

No dobra, widzę że skoro jednym działa, a innym nie działa, a jeszcze innym jednego dnia działa a innego nie to musimy wspólnie zdiagnozować problem.

Każdego kto ma jakiekolwiek problemy z wirtualnym access pointem (niewidoczna sieć wifi astroberry) albo jakikolwiek inny problem proszę o podanie w poście:

  1. Wersji Raspberry Pi
  2. Wyniku polecenia 1 wykonanego w terminalu na Raspberry
  3. Wyniku polecenia 2 wykonanego w terminalu na Raspberry
  4. Rodzaju urządzenia (PC/Tablet/Telefon/Lodówka/Suszarka do włosów) i informacji o systemie operacyjnym i wersji z jakiego łączycie się do Raspberry (Windows/Linux/Mac)
  5. Rodzaju routera wifi z którym próbujecie się połączyć z Raspberry
  6. Informacji o wspieranych trybach wifi B/G/N/AC na urządzeniu z pkt 4
  7. Informacji o wspieranych trybach wifi B/G/N/AC na routerze z pkt 5
  8. Informacji na temat tego, czy dokonywaliście jakichkolwiek zmian w konfiguracji Astroberry Server

 

Polecenie 1

 

sudo astroberry_vap status

 

Polecenie 2

grep Revision /proc/cpuinfo |awk -F: '{print $2}'|sed 's/\ //'

 

Bez tego nigdy nie będę w stanie znaleźć rozwiązania, które działa dla wszystkich.

Edytowane przez RadekK

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

U mnie przed chwilą uruchomił się VAP na raspberryPi B+

Po sprawdzeniu statusu 

sudo astroberry_vap status

Wyświetliło mi STOP

Po zalogowaniu się jako root wpisałem:

astroberry_vap start

wyświetliło :

Starting Virtual Access Point...

Virtual Access Point STARTED

 

Po chwili pojawiła sie dostępna sieć "astroberry" po połączeniu się z siecią w przeglądarce wpisałem http://192.168.10.1 i w końcu się połączyło (działa na PC win7, Laptopie win7 i telefonie z Androidem wszystkie obsługują tylko standard wifi b/g/n)  .

Jedyne zmiany które wprowadziłem to edycja pliku hostapd_3bplus.conf (hw_mode=g     channel=6 ) wg porad Radka.

I wpisanie danych do połączenia się z routerem który ma dostęp do internetu.

Zobaczcie może u was też zadziała

 

Dopiero teraz zauważyłem że po wyłączeniu raspberry ustawienia się nie zapisują i po włączeniu od nowa trzeba włączać VAP 

IMG_20181216_202901.jpg

Edytowane przez glaurung
  • Lubię 2

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

  • Polecana zawartość

    • Małe porównanie mgławic planetarnych
      Postanowiłem zrobić taki kolaż będący podsumowaniem moich tegorocznych zmagań z mgławicami planetarnymi a jednocześnie pokazujący różnice w wielkości kątowe tych obiektów.
      Wszystkie mgławice na tej składance prezentowałem i opisywałem w formie odrębnych tematów na forum więc nie będę się rozpisywał o każdym obiekcie z osobna - jak ktoś jest zainteresowany szczegółami bez problemu znajdzie fotkę danej mgławicy na forum.
        • Kocham
        • Dziękuję
        • Lubię
      • 20 odpowiedzi
    • SN 2018hhn - "polska" supernowa w UGC 12222
      Dziś mam przyjemność poinformować, że jest już potwierdzenie - obserwacja spektroskopowa wykonana na 2-metrowym Liverpool Telescope (La Palma, Wyspy Kanaryjskie). Okazuje się, że mamy do czynienia z supernową typu Ia. Poniżej widmo SN 2018hhn z charakterystyczną, silną linią absorpcyjną SiII.
        • Dziękuję
        • Lubię
      • 11 odpowiedzi
    • Zbiórka: Obserwatorium do poszukiwania nowych planet pozasłonecznych
      W związku z sąsiednim wątkiem o zasadach przyjmowania stypendiów, po Waszej radzie zdecydowałem się założyć zbiórkę crowdfundingową na portalu zrzutka.pl. W tym wątku będę informował o wszelkich aktualizacjach, przychodzących także po zakończeniu.
        • Kocham
        • Dziękuję
        • Lubię
      • 85 odpowiedzi
    • Mamy polską zmienną z zaćmieniowym dyskiem protoplanetarnym
      W ten weekend, korzystając z danych ASAS-SN (All Sky Automated Survey for Supernovae), wykryłem nieznaną do tej pory zmienną typu R Coronae Borealis. To jedna z najrzadszych typów gwiazd zmiennych - do tej pory odnaleziono zaledwie ~150. Ich poszukiwanie nie należy do najprostszych, gdyż swoimi wskaźnikami barwy (B-V, J-K etc.) nie wyróżniają się zbytnio, dlatego szybciej jest przeszukać krzywe blasku.
        • Lubię
      • 19 odpowiedzi
    • Odkrycia 144 gwiazd zmiennych
      W tym temacie przedstawiam wyniki trwającego pół roku amatorskiego projektu, którego celem było wyszukiwanie nowych gwiazd zmiennych. Podsumowując, udało mi się znaleźć 144 gwiazdy zmienne, jedna z nich to współodkrycie z Gabrielem Murawskim - układ binarny o znacznej ekscentryczności. Postanowiłem więc zakończyć projekt, by móc zając się tematem spektroskopii średnich rozdzielczości.
        • Kocham
        • Dziękuję
        • Lubię
      • 9 odpowiedzi
×

Powiadomienie o plikach cookie

Umieściliśmy na Twoim urządzeniu pliki cookie, aby pomóc Ci usprawnić przeglądanie strony. Możesz dostosować ustawienia plików cookie, w przeciwnym wypadku zakładamy, że wyrażasz na to zgodę.