Jump to content

Astroberry Server


Guest RadekK
 Share

Recommended Posts

15 minutes ago, wylam said:

Czyli po ustawieniu połączenia do swojej sieci wifi vap jest wyłączany na stałe i system nie sprawdza już tego przy uruchomieniu?

Nie na stałe. System sprawdza dostępność sieci w tle co jakiś czas w trakcie działania. Jeśli sieć będzie niedostępna to automatycznie uruchomi VAP. Dzięki temu nawet w przypadku utraty połączenia mamy możliwość podłączenia do VAP.

Link to comment
Share on other sites

Witam ponownie...moja malina ma znów swoje humory...poprzednio skorzystałem z edycji pliku hostapd.conf gdzie zmieniłem tryb sieci na g czyli 2.4gh oraz do pliku hostapd.conf w folderze default podstawiłem rubrykę 

DAEMON_CONF="/etc/hostapd/hostapd.conf"

Wszystko według instrukcji z tej strony.

https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md

I hot spot startował po 5-10 minutach, łaczyłem się i mogłem sterować przez vnc.

Dziś uruchamiam malinę chyba 10 raz i czekam i czekam i nie ma sieci. Niczego nie zmieniałem w ustawieniach i są one takie same, zmieniło się tylko to że brak punktu dostępu widocznego...co mogę zrobić? Ręce opadają normalnie. Heh

Link to comment
Share on other sites

1 hour ago, Selmak said:

DAEMON_CONF="/etc/hostapd/hostapd.conf"

W ten sposób zmieniłeś konfigurację systemu na własną. W efekcie w tle konkurują skrypty z Astroberry Server z Twoimi zmianami (hostapd działający jako usługa i konkurujący z automatem odpalającym go tak jak opisałem wyżej). Jeśli chcesz sam skonfigurować swój system to zacznij od wyłączenia automatu w pliku /etc/rc.local dodając # przed linią check-wlanconn > /dev/null 2>&1

Link to comment
Share on other sites

No dobra, widzę że skoro jednym działa, a innym nie działa, a jeszcze innym jednego dnia działa a innego nie to musimy wspólnie zdiagnozować problem.

Każdego kto ma jakiekolwiek problemy z wirtualnym access pointem (niewidoczna sieć wifi astroberry) albo jakikolwiek inny problem proszę o podanie w poście:

  1. Wersji Raspberry Pi
  2. Wyniku polecenia 1 wykonanego w terminalu na Raspberry
  3. Wyniku polecenia 2 wykonanego w terminalu na Raspberry
  4. Rodzaju urządzenia (PC/Tablet/Telefon/Lodówka/Suszarka do włosów) i informacji o systemie operacyjnym i wersji z jakiego łączycie się do Raspberry (Windows/Linux/Mac)
  5. Rodzaju routera wifi z którym próbujecie się połączyć z Raspberry
  6. Informacji o wspieranych trybach wifi B/G/N/AC na urządzeniu z pkt 4
  7. Informacji o wspieranych trybach wifi B/G/N/AC na routerze z pkt 5
  8. Informacji na temat tego, czy dokonywaliście jakichkolwiek zmian w konfiguracji Astroberry Server

 

Polecenie 1

 

sudo astroberry_vap status

 

Polecenie 2

grep Revision /proc/cpuinfo |awk -F: '{print $2}'|sed 's/\ //'

 

Bez tego nigdy nie będę w stanie znaleźć rozwiązania, które działa dla wszystkich.

Edited by RadekK
Link to comment
Share on other sites

U mnie przed chwilą uruchomił się VAP na raspberryPi B+

Po sprawdzeniu statusu 

sudo astroberry_vap status

Wyświetliło mi STOP

Po zalogowaniu się jako root wpisałem:

astroberry_vap start

wyświetliło :

Starting Virtual Access Point...

Virtual Access Point STARTED

 

Po chwili pojawiła sie dostępna sieć "astroberry" po połączeniu się z siecią w przeglądarce wpisałem http://192.168.10.1 i w końcu się połączyło (działa na PC win7, Laptopie win7 i telefonie z Androidem wszystkie obsługują tylko standard wifi b/g/n)  .

Jedyne zmiany które wprowadziłem to edycja pliku hostapd_3bplus.conf (hw_mode=g     channel=6 ) wg porad Radka.

I wpisanie danych do połączenia się z routerem który ma dostęp do internetu.

Zobaczcie może u was też zadziała

 

Dopiero teraz zauważyłem że po wyłączeniu raspberry ustawienia się nie zapisują i po włączeniu od nowa trzeba włączać VAP 

IMG_20181216_202901.jpg

Edited by glaurung
  • Like 1
Link to comment
Share on other sites

U mnie powyższy sposób zadziałał, ale muszę się zalogować jako root, bo po wpisaniu komendy - sudo astroberry_vap start  - mam widoczny AP "Astroberry" i ładnie się łączy z moim tabletem, tyle że jednorazowo i po restarcie trzeba uruchamiać ponownie. Stary laptop tego już kompletnie nie widzi.

Tablet Toshiba ma system WIN 8.1 i zero problemów z WiFi, który według opisu w systemie jest typem 802.11 abgn (czyżby 2,4/5GHz???), a laptop to leciwiec z WIN XP i WiFi opartym na adapterze 2200BG (tak stoi w menadżerze urządzeń).

Reszta prób jutro, bo podpieram się rzęsami...

Dzięki wszystkim za pomoc i wsparcie :Beer:

P.S.

Właśnie teraz zauważyłem, że nie tylko mnie ustawienia się nie zapisują :D

Jakby nie było, już przynajmniej krok do przodu ;)

Edited by Piotrek L.
Link to comment
Share on other sites

4 godziny temu, RadekK napisał:

W ten sposób zmieniłeś konfigurację systemu na własną. W efekcie w tle konkurują skrypty z Astroberry Server z Twoimi zmianami (hostapd działający jako usługa i konkurujący z automatem odpalającym go tak jak opisałem wyżej). Jeśli chcesz sam skonfigurować swój system to zacznij od wyłączenia automatu w pliku /etc/rc.local dodając # przed linią check-wlanconn > /dev/null 2>&1

Przywrociłem to co było pierwotnie, skasowałem tą linijkę w etc/default/hostapd by się to nie kłóciło ze sobą.. Dwa restarty po 15 minut i brak widocznej sieci. Chyba dam sobie spokój z tym do wyjścia astroberry pod ten model.

 

Skoro ręczne uruchamianie hot spota działa..czy da radę napisać jakiś skrypt czy auto laucher takiej komendy w terminalu po uruchomieniu? Mi by to wystarczyło.

Edited by Selmak
Link to comment
Share on other sites

Dzięki zaangażowaniu @glaurung prawdopodobnie znaleziony został problem! Okazuje się, że różne wersje 3B+ inaczej się identyfikują i system głupieje, źle wykrywając wersję.

Tych z Was którzy mają problem z VAP proszę o zastąpienie oryginalnego skryptu wersją załączoną do tego posta. Jak to zrobić?

1. Zapisujemy skrypt w /home/astroberry

2. Nadpisujemy oryginalny skrypt: sudo cp /home/astroberry/astroberry_vap /usr/local/bin/astroberry_vap

3. Ustawiamy poprawne uprawnienia: sudo chmod 755 /usr/local/bin/astroberry_vap

4. Restart systemu

 

NOWY SKRYPT

 

PS. Tych z Was którzy nie są oswojeni z linuxem uspokajam. Po tym jak potwierdzi się, że ta zmiana rozwiązuje problem opublikuję nowy obraz systemu do nagrania na kartę SD ;)

 

 

Edited by RadekK
Link to comment
Share on other sites

W dniu 16.12.2018 o 19:27, RadekK napisał:

No dobra, widzę że skoro jednym działa, a innym nie działa, a jeszcze innym jednego dnia działa a innego nie to musimy wspólnie zdiagnozować problem.

Każdego kto ma jakiekolwiek problemy z wirtualnym access pointem (niewidoczna sieć wifi astroberry) albo jakikolwiek inny problem proszę o podanie w poście:

  1. Wersji Raspberry Pi
  2. Wyniku polecenia 1 wykonanego w terminalu na Raspberry
  3. Wyniku polecenia 2 wykonanego w terminalu na Raspberry
  4. Rodzaju urządzenia (PC/Tablet/Telefon/Lodówka/Suszarka do włosów) i informacji o systemie operacyjnym i wersji z jakiego łączycie się do Raspberry (Windows/Linux/Mac)
  5. Rodzaju routera wifi z którym próbujecie się połączyć z Raspberry
  6. Informacji o wspieranych trybach wifi B/G/N/AC na urządzeniu z pkt 4
  7. Informacji o wspieranych trybach wifi B/G/N/AC na routerze z pkt 5
  8. Informacji na temat tego, czy dokonywaliście jakichkolwiek zmian w konfiguracji Astroberry Server

 

Świeżo zainstalowany system na nowej karcie sd.


  1. RPi 3B
  2. Virtual Access Point STARTED ( ap astroberry nie pojawia się)
  3. a22082
  4. Laptop MacBook Air, MacOS, laptop z windowsem. tablet z androidem, telefon iphone
  5. Linksys  TL-WDR4300
  6. B/G/N/AC
  7.  B/G/N
W dniu 16.12.2018 o 23:56, RadekK napisał:

Dzięki zaangażowaniu @glaurung prawdopodobnie znaleziony został problem! Okazuje się, że różne wersje 3B+ inaczej się identyfikują i system głupieje, źle wykrywając wersję.

Tych z Was którzy mają problem z VAP proszę o zastąpienie oryginalnego skryptu wersją załączoną do tego posta. Jak to zrobić?

1. Zapisujemy skrypt w /home/astroberry

2. Nadpisujemy oryginalny skrypt: sudo cp /home/astroberry/astroberry_vap /usr/local/bin/astroberry_vap

3. Ustawiamy poprawne uprawnienia: sudo chmod 755 /usr/local/bin/astroberry_vap

4. Restart systemu

 

astroberry_vap

 

PS. Tych z Was którzy nie są oswojeni z linuxem uspokajam. Po tym jak potwierdzi się, że ta zmiana rozwiązuje problem opublikuję nowy obraz systemu do nagrania na kartę SD ;)

U mnie to nie działa.

 

astroberry_vap status 

/usr/local/bin/astroberry_vap: line 17: [: missing `]'
/usr/local/bin/astroberry_vap: line 17: a22082: command not found
/usr/local/bin/astroberry_vap: line 17: a22082: command not found
Virtual Access Point STARTED

 

Link to comment
Share on other sites

  • 2 weeks later...
W dniu ‎15‎.‎12‎.‎2018 o 01:27, Sebo_b napisał:

Malina nie ma zegara RTC, rozwiązań jest kilka:

- dokupić zegar (najlepiej z GPS),

- jak masz podłączony Pi do internetu to ntp powinno pobrać date i czas,

- ustawiać ręcznie po każdym włączeniu.

 

Jako ciekawostkę napiszę, że moduł wifi z wersji 3B+ obsługuje tryb dualny - tzn jest i AP i klientem w tym samym czasie (oczywiście na tym samym kanale bo jest jedno radio). Tak to działa u mnie i wydaje się stabilne. Tylko kwestia konfiguracji, która zabrała mi 2 wieczory przez prostą rzecz (hostapd musi wstać wcześniej niż wpa-supplicant). 

Hej.. problemy jakie gnębiły moje rpi 3b+ zostały rozwiązane..pozostaje mi tylko sprawa tego zegara RTC.

To więc jaki kupić? na bootland widzę kilka opcji zakupu..ale nie mam doświadczenia w używaniu rpi i nie wiem co powinienem wybrać.

Zauważam że nie które zegary podłącza się w piny blisko radiatorów co wymusza zdjęcie radiatora, chciałbym tego uniknąć.

Polecicie coś?

Link to comment
Share on other sites

Jak już pisał Radek problem z nowymi RaspberryPi 3B+ został już rozwiązany.
Można już ściągnąć obraz systemu z poprawionym skryptem który prawidłowo rozpoznaję wersje komputera.
W wersji 3B+ WiFi odpala się domyślnie w trybie AC.
Jeżeli macie komputery które nie obsługują jeszcze tego trybu sieci to musicie edytować plik:
hostapd_3bplus.conf

/etc/hostapd/hostapd_3bplus.conf 

Trzeba otworzyć go jako administrator
zmienić: hw_mode=g 
              channel=6
Zatwierdzić i zrestartować.
Punkt VAP odpala się ok 2 minuty po włączeniu.

 

Wielkie Podziękowania dla Radka

Link to comment
Share on other sites

Potwierdzam, że nowy system działa bez zarzutu, ale tylko jeśli używam mojego tabletu z nowym systemem WiFi.

VAP odpala się automatycznie już po krótkiej chwili.

Dla starego systemu potrzebna jest konfiguracja WiFi.

Problem mam za to z czymś innym. Nie mogę odpalić stabilnie ASI 120mm żadnym programem, który mam razem z Astroberry.

Próbowałem zainstalować nową wersję OpenAstro https://github.com/openastroproject/openastro/releases, ale wywala mi jakieś dziwne błędy podczas instalacji.

Plik mam rozpakowany (przez RPi) do formatu .tar ale kompletnie nie wiem co dalej... :(  Nazwa pliku to "openastro-1.5.0.tar". Gdyby ktoś był tak miły i napisał komendy do instalacji (deinstalacji starego) to będę bardzo wdzięczny.

Stara wersja 1.0.0 jest standardowo z Astroberry server, ale nie działa z moją kamerką.

Pozdrawiam w Nowym Roku :Beer:

 

 

Link to comment
Share on other sites

Te pakiety to kod źródłowy - musiałbyś go skompilowac żeby działał (a to zdecydowanie wykracza poza napisanie jak się rozpakowuje tar.gz).

 

Nie możesz po prostu odpalić kstars, tam ekos i nim robić akwizycję? Kamery ZWO powinny działać bez problemu w ekosie. 

Link to comment
Share on other sites

Guest RadekK
2 hours ago, Piotrek L. said:

Nie mogę odpalić stabilnie ASI 120mm żadnym programem, który mam razem z Astroberry.

Chyba źle sprawdzałeś ;) Sam używam ASI 120MM do guidingu i planet więc wiem, że działa.

  • PHD2 obsługuje tę kamerę bez najmniejszego problemu
  • DSO - Wystarczy odpalić KStars i wybrać kamerę w profilu Ekos
  • Planety - oaCapture i Planetary Imager działają bez problemu

Tutaj jedna uwaga - kamera ASI 120MM w wersji USB 2.0 współpracuje z linuxem bez problemu, pod warunkiem że ma wgrany firmware w wersji "compatible". Z innym firmwarem kamera działa, ale gubi klatki (problem szybkości USB 2.0 przy szybkim streamingu w pełnej rozdzielczości). Nie wpływa to na wykrywalność kamery przez ww. oprogramowanie.

 

PS. oaCapture aka OpenAstro sprawdzę jeszcze u siebie, bo być może jakaś ostatnia aktualizacja coś popsuła...

Edited by RadekK
Link to comment
Share on other sites

Guest RadekK

Astroberry Server jest tak skonfigurowany, że automatycznie pobierze czas z GPS. Nic nie musisz robić poza podłączeniem GPS do RPi i ew. skonfigurowaniem portu GPS w pliku /etc/default/gpsd

Link to comment
Share on other sites

5 godzin temu, r.ziomber napisał:

Ok to mi rzuca trochę swiatła na sprawę...

A czy coś poręczniejszego? jakiś gps na usb ( wielkości pendrive ) ? znajdzie się ?

Czego wy używacie?.

 

Sprawdzi się? warto kupić? 

https://www.banggood.com/pl/VK-172-USB-GPS-Receiver-Dongle-Adapter-Smart-Antenna-Module-For-Gmouse-Glonass-p-1123502.html?gmcCountry=PL&currency=EUR&createTmp=1&utm_source=googleshopping&utm_medium=cpc_bgs&utm_content=zouzou&utm_campaign=pla-pl-css-elc2-pc&cur_warehouse=CN

Edited by Selmak
Link to comment
Share on other sites

2 minuty temu, rambro napisał:

Jak nie potrzebujesz GPS to najtaniej wychodzi sprzętowy RTC. Ja zastosowałem taki: https://kamami.pl/moduly-rozszerzajace-rpi-3-model-ab/233506-rpi-raspberry-pi-rtc-ds3231-modul-zegara-rtc-dla-raspberry-pi.html 

Wygląda w porządku...ale czy nie koliduje z radiatorami po podłączeniu?

Link to comment
Share on other sites

 

Ja mam takiego podłączonego bezpośrenio po UART - kupiłem jak były jeszcze po 175PLN. Działa bardzo dobrze, a GPS sprawia, że nie trzeba lokacji w KStart ustawiać. Myślę, że takie po 70PLN też będą dobrze działać (ja chciałem go z I2C). Całość mieści się w obudowie od Raspi przyklejone gorącym klejem - te moduły są naprawdę małe. 

 sparkfun-xa1110-modul-gps-mediatek-mt3333-10hz-i2cuart.jpg.e5b9eb8332c2a4cc4a6a66b08ab9e766.jpg

Link to comment
Share on other sites

Witam ponownie.

Niestety trzeba powalczyc dalej.. bo jeszcze wiele nie dziala jak nalezy.

Pierwszym problemem są ciagle restarty zapamietanych ustawien Canona 450d, pod sterownikami gphoto oraz Canon DSLR, mimo ze klikam za kazdym razem "save" w panelu indi w ustawieniach urzadzenia..to ekos ciagle prosi o podanie parametrow obrazu za kazdym razem kiedy wejde w zakładke CCD..mimo ze wyswietla ze je juz posiada.

Denerwujace to, a co najwazniejsze przez tego canona barzdzo czesto crashuje mi kstars z ekosem..nie wyobrazam sobie sesji pod pogodnym niebem z co 5 minut wylaczajacym sie kstars. Wybaczcie ze tak lamana polszczyzna pisze, ale slownik polski niestety nie dziala.

Trzeba rozwiazac problem, mysle ze wspolnie damy rade.

Pozdrawiam.

 

Screenshot at 2019-01-02 16-53-15.png

Screenshot at 2019-01-02 16-53-32.png

Link to comment
Share on other sites

Guest RadekK

Z Canonem nie pomogę, bo nie używam. Darek vel @Nowok76 możesz się wypowiedzieć? Wiem, że Ty używasz w swoim setupie.

Właściwie tylko jedno pytanie (bo kojarzę jakąś dyskusję w tym temacie) - używasz sterownika indi_canon_ccd czy indi_gphoto_ccd? Ten drugi to generyczny sterownik dla lustrzanek cyfrowych, który chyba zawsze działał bez problemów. Sprawdź pls i daj znać

 

NB. Kopalnią wiedzy na temat specyficznych problemów ze sprzętem jest Forum INDI

Edited by RadekK
Link to comment
Share on other sites

6 minut temu, RadekK napisał:

Z Canonem nie pomogę, bo nie używam. Darek vel @Nowok76 możesz się wypowiedzieć? Wiem, że Ty używasz w swoim setupie.

Właściwie tylko jedno pytanie (bo kojarzę jakąś dyskusję w tym temacie) - używasz sterownika indi_canon_ccd czy indi_gphoto_ccd? Ten drugi to generyczny sterownik dla lustrzanek cyfrowych, który chyba zawsze działał bez problemów. Sprawdź pls i daj znać

 

NB. Kopalnią wiedzy na temat specyficznych problemów ze sprzętem jest Forum INDI

indi_canon_ccd i indi_gphoto_ccd, testowałem na obu tych sterownikach. Efekt jest taki sam.

Szczerze 2 lata temu kiedy poznałem co to Kstars i Ekos, używałem na laptopie z tymi sterownikami.. (dokładnie ten sam sprzęt) no i nie było takich kłopotów.

Poszukam w sieci informacji na ten temat, jeśli sam rozwiąże problem to opisze jak go naprawiłem.

Tym czasem zobaczymy co na to Nowok76.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Our picks

    • Droga Mleczna w dwóch gigapikselach
      Zdjęcie jest mozaiką 110 kadrów, każdy po 4 minuty ekspozycji na ISO 400. Wykorzystałem dwa teleskopy Takahashi Epsilon 130D i dwa aparaty Nikon D810A zamocowane na montażu Losmandy G11 wynajętym na miejscu. Teleskopy były ustawione względem siebie pod lekkim kątem, aby umożliwić fotografowanie dwóch fragmentów mozaiki za jednym razem.
        • Like
      • 41 replies
    • Przelot ISS z ogniskowej 2350 mm
      Cześć, po kilku podejściach w końcu udało mi się odpowiednio przygotować cały sprzęt i nadążyć za ISS bez stracenia jej ani razu z pola widzenia. Wykorzystałem do tego montaż Rainbow RST-135, który posiada sprzętową możliwość śledzenia satelitów.
      Celestron Edge 9,25" + ZWO ASI183MM. Czas ekspozycji 6 ms na klatkę, końcowy film składa się z grup 40 klatek stackowanych, wyostrzanych i powiększonych 250%.
      W przyszłości chciałbym wrócić do tematu z kamerką ASI174MM, która z barlowem 2x da mi podobną skalę, ale 5-6 razy większą liczbę klatek na sekundę.
      Poniżej film z przelotu, na dole najlepsza klatka.
        • Like
      • 70 replies
    • Big Bang remnant - Ursa Major Arc or UMa Arc
      Tytuł nieco przekorny bo nie chodzi tu oczywiście o Wielki Wybuch ale ... zacznijmy od początku.
       
      W roku 1997 Peter McCullough używając eksperymentalnej kamery nagrał w paśmie Ha długą na 2 stopnie prostą linie przecinajacą niebo.
       
      Peter McCullough na konferencji pokazał fotografię Robertowi Benjamin i obaj byli pod wrażeniem - padło nawet stwierdzenie: “In astronomy, you never see perfectly straight lines in the sky,”
        • Like
      • 16 replies
    • Jeśli coś jest głupie, ale działa, to nie jest głupie - o nietypowych rozwiązaniach sprzętowych
      Sformułowanie, które można znaleźć w internetach jako jedno z "praw Murphy'ego" przyszło mi na myśl, gdy kolejny raz przeglądałem zdjęcia na telefonie z ostatniego zlotu, mając z tyłu głowy najgłośniejszy marsjański temat na forum. Do rzeczy - jakie macie (bardzo) nietypowe patenty na usprawnienie sprzętu astronomicznego bądź jakieś kreatywne improwizacje w razie awarii czy niezabrania jakiegoś elementu sprzętu  Obstawiam, że @HAMAL mógłby samodzielnie wypełnić treścią taki wątek.
        • Haha
        • Like
      • 43 replies
    • MARS 2020 - mapa albedo powierzchni + pełny obrót 3D  (tutorial gratis)
      Dzisiejszej nocy mamy opozycję Marsa więc to chyba dobry moment żeby zaprezentować wyniki mojego wrześniowego projektu. Pogody ostatnio jak na lekarstwo – od początku października praktycznie nie udało mi się fotografować. Na szczęście wrzesień dopisał jeśli chodzi o warunki seeingowe i udało mi się skończyć długo planowany projekt pełnej mapy powierzchni (struktur albedo) Marsa.
        • Like
      • 132 replies
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.