Jump to content

Astroberry Server


Recommended Posts

Jedyne ostatnie niekontrolowane zamykanie Kstars miałem przy zmianie obszaru analizy gwiazd na zdjęciu. Po kliknięciu na nowy obszar Kstars czasami "znika". Używam Astroberry jako serwera Indi, a Kstars mam uruchomione w domu na Win10. 

Po ostatnich zmianach plate solve trwa około sekundy, ale zmiana setupu (inny teleskop, ta sama kamera) powodowała chwilowe problemy z działaniem plate solve.

Link to post
Share on other sites

Jeszcze dwa pytania mam

SGP ma świetną funkcjonalność do wznawiania sesji po np błędzie guidingu. Przykładowo chmury wychodzą, guiding gubi gwiazdę, SGP w interwałach próbuje przywrócić sesję. Chmury przechodzą, SPG robi powtórnie centrowanie na obiekt i jedzie dalej z sesją. Czy KStars/Ekos/CCDCiel coś takiego ma?

 

i drugie - czy Ekos przerywa naświetlanie klatki (i zaczyna nową) po wystąpieniu określonego błędu w guidowaniu?

 

P.

Link to post
Share on other sites

Niezły cukierek te Astroberry. Jak zawsze nie chciał robić zdjęć, tak wczoraj mogłem ustawić sesję i zrobił całe 50 zdjęć. 

Problem główny polegał na tym, że nie chciał skierować montażu na niektóre wybrane obiekty :haha: W tym na ten, który planowałem, bo po co :Boink:

Poza tym w kratkę mam problem z parkowaniem na dzień dobry. Rozpoczynając sesję, w indi czyszczę ustawienia położenia, przywracam dane i parkuję (jak to zostało wytłumaczone w jednym z tutoriali na yt). Mimo to nie zawsze montaż reaguje.  Ogólnie to mniejszy problem, bo wyparkuje manualnie, na oko, a później sync zrobi swoje. 

Żeby to był jeden błąd powtarzający się regularnie. A tu kilka różnych wg kaprysu. To już chyba nie jest zależne ode mnie? 

 

Link to post
Share on other sites

A ja z kolei chciałem zaktualizować wszystko i dostałem to:

 

astroberry@astroberry:~ $ sudo apt update && sudo apt upgrade && sudo apt dist-upgrade
Ign:2 https://www.astroberry.io/repo buster InRelease                                                                             
Pobieranie:3 http://raspbian.raspberrypi.org/raspbian buster InRelease [15,0 kB]                                                          
Pobieranie:4 http://archive.raspberrypi.org/debian buster InRelease [32,8 kB]                                                                                                                                      
Pobieranie:5 https://linux.teamviewer.com/deb stable InRelease [11,0 kB]                                                                                                                                                 
Pobieranie:1 http://vega.ap-i.net/apt unstable InRelease [3 622 B]                                                                                                               
Błąd:6 https://www.astroberry.io/repo buster Release                                                                                                    
  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses not yet valid certificate.  Could not handshake: Error in the certificate verification. [IP: 87.98.235.184 443]
Czytanie list pakietów... Gotowe                                                                                                                                                                                                             
E: Release file for http://raspbian.raspberrypi.org/raspbian/dists/buster/InRelease is not valid yet (invalid for another 75dni 16g 8min 45s). Updates for this repository will not be applied.
E: Release file for http://www.ap-i.net/apt/dists/unstable/InRelease is not valid yet (invalid for another 75dni 9g 44min 43s). Updates for this repository will not be applied.
E: Release file for https://linux.teamviewer.com/deb/dists/stable/InRelease is not valid yet (invalid for another 69dni 20g 47min 42s). Updates for this repository will not be applied.
E: The repository 'https://www.astroberry.io/repo buster Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Release file for http://archive.raspberrypi.org/debian/dists/buster/InRelease is not valid yet (invalid for another 75dni 19g 55min 19s). Updates for this repository will not be applied.
 

Link to post
Share on other sites

Prawodpodobnie uruchomiłeś update zanim zaktualizował Ci się czas na RPi.

 

17 minutes ago, isset said:

is not valid yet (invalid for another 75dni 19g 55min 19s)

 

innymi słowy: (certyfikat) jeszcze nie jest ważny (nie ważny przez kolejne 75 dni 19g 55min 19s).

 

W efekcie Twój system, który jest w przeszłości uznaje za nieważny aktualny certyfkat, bo dla niego jest w przyszłości ;-)

 

  • Thanks 1
Link to post
Share on other sites

Czy występował u was taki problem?
 

Cytat

2021-02-23T00:16:30 Odrzucono kalibrację. Dryf gwiazdy jest za krótki. Sprawdź montaż, kable, lub problemy z podmuchem powrotnym.

 

90% prób odpalenia guidingu kończy się właśnie w ten sposób.

Edited by OnlyAfc
Link to post
Share on other sites
7 godzin temu, OnlyAfc napisał:

Czy występował u was taki problem?
 

 

90% prób odpalenia guidingu kończy się właśnie w ten sposób.

Po ostatniej aktualizacji  zdażalo się, nie jestem pewien, ale ma to związek że z automatu bierze wiele gwiazd i gdy przesuwa się kwadrat próbkowania -przeskakuje na inne, nowe gwiazdy i się gubi.

Wydłużylem czas impulsu do 1000ms

- co najmniej 5-10 klatek

- I do kalobracji wskazuje pole na ktorym jest  1 gwiazda

 

M.

Link to post
Share on other sites

U mnie przyczyna była inna, ale trochę dziwna.

Jak zmieniałem kard, przesuwał się teleskop, to guiding automatycznie się odpala. W statusie widać, że obiekt jest guidowany, ale teraz ciekawostka, jak przechodzę na ekrain guindingu, to pokazuje, że prowadzenia nie ma. Ja w swojej niewiedzy, ustawiam ponownie prowadzenie, ale podczas kalibracji gwiazdki się nie przesuwają, bo ... teleskop jest już prowadzony.

Musiałem kliknąć rozłączenie ze wszystkim i ponowne połączenie i zadziałała kalibracja za pierwszym razem.

Link to post
Share on other sites
W dniu 22.02.2021 o 00:51, OnlyAfc napisał:

Polar Align za chiny nie jest intuicyjny. Z 40min walczyłem, żeby zrozumieć, czemu nie potrafi zweryfikować kadru. Przez astro.net w ogóle nie szło, dopiero z użyciem ASTAP i 10 s. klatkach, udało mi się w cały proces przejść. Dodatkowo miałem ogromny problem z przybliżeniem widoku, do ustawienia gwiazdy. Gdzieś widziałem filmik na YT, że da się ten widok dać na pełny ekran (czego nie znalazłem) oraz, że w przyszłości będzie wyniesiony do aplikacji mobilnej (o ile czegoś nie pokręciłem). Ogólnie prawie 1h straciłem, żeby normalnie PA ustawić.

 

 

  • Like 1
Link to post
Share on other sites

Wczoraj poszło mi zdecydowanie lepiej, w kilka minut miałem ustawione.

Ogólnie uczę się tego narzędzia, są rzeczy, które wydają mi się dziwne lub działają nie do końca dla mnie intuicyjnie, ale udało mi się wczoraj 4h sesję zrobić testową i niemal wszystko działało.

 

Z rzeczy, które mi zostały do opanowania lub wg. mnie są bug-ami to:

  • czasem kstars pokazuje mi view z kamery, który nie zgadza się z tym, który widzę na próbnych strzałach. Robiłem synchrobizację, znajdywanie montażu itd, ale głównie obrót kamery się nie zgadzał.
  • Wczoraj ustawiłem, żeby montaż pokierować na SH2-155 (mgławica grota). Montaż dotarł zgodnie z tym, co pokazywał Kstars, ale mgławica była na dole kadru a nie w środku. Musiałem ją ręcznie skorygować i ustawić w kadrze. Troszkę dziwne, bo wg. siatki, wyświetlanej w Kstars, to montaż trafił w odpowiednie koordynaty (w stellarium też się zgadzały)
  • Miałem problemy z guidingiem troszkę, ale to już wyżej napisałem, i jak poprawiłem.
  • Nadal nie rozkminiłem, jak włączyć widok przy polar align na pełny ekran :)
  • Ciekawie zachowuje się wyszukiwarka. Zdarzyło mi się wpisać obiekt w wyszukiwarce, na liście się nie pojawiał (tak jakby nie znaleziony) a jak kliknąłem enter, to jednak na mapie go znajdywało i spokojnie można było montaż kierować na niego.
  • Like 1
Link to post
Share on other sites
25 minut temu, OnlyAfc napisał:

czasem kstars pokazuje mi view z kamery, który nie zgadza się z tym, który widzę na próbnych strzałach. Robiłem synchrobizację, znajdywanie montażu itd, ale głównie obrót kamery się nie zgadzał.

Kstars pokazuje obraz z plate solve i ramkę symulowanego widoku. U mnie symulowana ramka jest żółta, a ta z plate solve biała. Czy na 100% ta źle pokazująca była z plate solve? 

Link to post
Share on other sites

No to teraz pojawił się problem u mnie.

Kamera ASI1600MM-C + koło ZWO EFW

 

Ustawiłem w Ekos kamerę i koło na Mode:" Remote, tylko w tym trybie mogę ustawić w Aux: Astrolinka

Uruchomiłem Ekos'a, kamera i koło się podłączyło (koło słychać jak zrobiło kółko)

Po wybraniu parametrów zdjęcia i wybraniu filtru nacisnąłem preview - zdjęcie załadowano do Fits viewera i jest git. Zmieniłem filtr i znowu preview - tym razem koło nie drgnęło i nic się nie dzieje, ekspozycji brak a kółeczko przy "Changing filter" kręci się non stop

obraz.png

 

Rozłączyłem sprzęt, podłączyłem znowu i dostaję komunikat: 2021-02-23T13:20:35: [ERROR] Connect(): EFWOpen() = 4

a kamera w ogóle nie chce się połączyć...

 

słabo to wróży jak na razie :-/

Muszę wszystko poodpinać i dopiero wtedy rusza (ew. załadować ponownie driver w INDI Web Manager)

 

Macie jakiegoś pomysła?

Link to post
Share on other sites
35 minut temu, Pav1007 napisał:

koło słychać jak zrobiło kółko

 

A koło nie robi testowego obrotu po prostu jak dostanie zasilanie? Pytam, bo może wcale Twoje koło nie podłączyło się. Ja z kołem mam cały czas problem. Działa albo focuser, albo koło, nigdy razem.

Link to post
Share on other sites
Teraz, isset napisał:

A koło nie robi testowego obrotu po prostu jak dostanie zasilanie? Pytam, bo może wcale Twoje koło nie podłączyło się. Ja z kołem mam cały czas problem. Działa albo focuser, albo koło, nigdy razem.

Zapewne gdyż ponieważ że CCDCiel łączy się też z już istniejącym serwerem INDI. Jak w Ekos wybierzesz tryb Local i wskażesz koło i kamerę to śmiga aż miło. Bez najmniejszego problemu. Zebrałem testowo 20 klatek na różnych filtrach i na różnych czasach. na Remote nie mogłem zebrać dwóch klatek.

 

mówię o tym trybie:

obraz.png

 

Problemem jest na razie dodanie sterownika Astrolinka 4 USB tak by działał lokalnie https://github.com/astrojolo/astrolink4usb

Postępując krokami z tej strony mogę go potem tylko dodać do INDI Web Managera... lub ja się nie znam (co jest dużo bardziej prawdopodobne)

  • Like 1
Link to post
Share on other sites
6 minut temu, isset napisał:

 

A koło nie robi testowego obrotu po prostu jak dostanie zasilanie? Pytam, bo może wcale Twoje koło nie podłączyło się. Ja z kołem mam cały czas problem. Działa albo focuser, albo koło, nigdy razem.

Przez USB hub montaż gryzie się u mnie  i z fokuserem Sesto Senso2 i z Dream Fokuserem. Jak podłączam kamery i montaż przez hub, a fokuser bezpośrednio do innego portu USB w Rpi, to wszystko działa. Czasami potrzebny jest reboot malinki po podłączeniu wszystkiego.

  • Like 1
Link to post
Share on other sites
2 minuty temu, apolkowski napisał:

Jak podłączam kamery i montaż przez hub, a fokuser bezpośrednio do innego portu USB w Rpi, to wszystko działa.

 

Takiego ustawienia na próbowałem, dziś spróbuję. Dzięki!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   1 member

  • Our picks

    • Jeśli coś jest głupie, ale działa, to nie jest głupie - o nietypowych rozwiązaniach sprzętowych
      Sformułowanie, które można znaleźć w internetach jako jedno z "praw Murphy'ego" przyszło mi na myśl, gdy kolejny raz przeglądałem zdjęcia na telefonie z ostatniego zlotu, mając z tyłu głowy najgłośniejszy marsjański temat na forum. Do rzeczy - jakie macie (bardzo) nietypowe patenty na usprawnienie sprzętu astronomicznego bądź jakieś kreatywne improwizacje w razie awarii czy niezabrania jakiegoś elementu sprzętu  Obstawiam, że @HAMAL mógłby samodzielnie wypełnić treścią taki wątek.
        • Haha
        • Like
      • 21 replies
    • MARS 2020 - mapa albedo powierzchni + pełny obrót 3D  (tutorial gratis)
      Dzisiejszej nocy mamy opozycję Marsa więc to chyba dobry moment żeby zaprezentować wyniki mojego wrześniowego projektu. Pogody ostatnio jak na lekarstwo – od początku października praktycznie nie udało mi się fotografować. Na szczęście wrzesień dopisał jeśli chodzi o warunki seeingowe i udało mi się skończyć długo planowany projekt pełnej mapy powierzchni (struktur albedo) Marsa.
        • Love
        • Thanks
        • Like
      • 130 replies
    • Aktualizacja silnika Astropolis - zgłaszanie uwag
      Dzisiaj zaktualizowaliśmy silnik Astropolis do najnowszej wersji (głównie z powodów bezpieczeństwa). Najpoważniejsze błędy zostały już naprawione, ale ponieważ aktualizacja jest dosyć rozbudowana (dotyczy także wyglądu), drobnych problemów na pewno jest więcej. Bez was ich nie namierzymy. Dlatego bardzo proszę o pomoc i wrzucanie tu informacji o napotkanych problemach/błędach.
        • Like
      • 238 replies
    • Insight Investment Astrophotographer of the Year 2020 – mój mały-wielki sukces :)
      Jestem raczej osobą która nie lubi się chwalić i przechwalać… ale tym razem jest to wydarzenie dla mnie tak ważne, że postanowiłem podzielić się z Wami tą niezwykle radosną dla mnie wiadomością.
       
      Moja praca zajęła pierwsze miejsce w kategorii „Planety, komety i asteroidy” podczas tegorocznego konkursu Insight Investment Astronomy Photographer of the Year 2020.
        • Love
        • Thanks
        • Like
      • 85 replies
    • Zobaczyć powierzchnię Wenus.... - mapa promieniowania termicznego (sezon 2020)
      Zacznę od zdjęcia a potem będą technikalia, opisy zbierania materiału oraz informacje o obróbce
      6 maja faza Wenus zmalała poniżej 20% więc zaczął się najlepszy okres kiedy możemy podejmować próby rejestracji promieniowania termicznego powierzchni Wenus. Czas ten potrwa mnie więcej 17-18 maja kiedy to planeta będzie już zbyt blisko Słońca i kontrast zmaleje uniemożliwiając (lub utrudniając) rejestrację tego zjawiska.
        • Love
        • Thanks
        • Like
      • 30 replies
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.